Знакомство с

Жизнь в сети наполнена опасностями: Интернет-черви, программы-шпионы, троянские кони и другие вредоносные программы могут причинить вред системе, выражающийся в замедлении ее работы, падениях и краже личных данных. Для обеспечения необходимой защиты в это время кибер-воров и сетевых вымогателей ваш брандмауэр должен контролировать весь входящий и исходящий трафик и защищать вас от несанкционированных вторжений, делая ваш компьютер невидимым для всех, кому не позволено его видеть.

Признанный представляет собой мощный набор средств, основанных на новейших технологиях персональной защиты, что делает его наилучшим выбором для вашей системы.

С вы:

  • Всегда знаете, что происходит на вашем компьютере

    • контролирует каждое соединение между вашим комьютером и сетью Интернет, немедленно оповещая вас обо всех подозрительных соединениях и предоставляя вам возможность предпринять необходимое действие.

  • Защищены от атак хакеров автоматической интеллектуальной защитой

    • Модуль Детектор атак автоматически блокирует сканирование сети, атаки и другие удаленные попытки получить доступ к вашему компьютеру.

  • Сохраняете ваши действия в сети конфиденциальными

    • Модуль Интерактивные элементы блокирует потенциально опасные сценарии, которые могут захватить контроль над вашим браузером, а также другие компоненты веб-сайтов, которые могут отслеживать ваши предпочтения в сети и историю посещений. Полностью интегрированная защита от spyware предотвращает заражение компьютера spyware-программами и блокирует spyware до того, как они доберутся до ваших данных.

  • Контролируете как приложения обмениваются данными с сетью

    • Контроль компонентов, Контроль скрытых процессов и Контроль памяти процессов позволяют вам решать что разрешается делать приложениям и процессам на вашем компьютере и какие исходящие соединения им позволены. Spyware не смогут совершить звонок с компьютера, защищенного .

  • Осознаете существующие угрозы

    • Журнал событий позволяет вам просматривать историю ваших Интернет-соединений, включая списки заблокированных сайтов, отраженных атак и еще более дюжины различных журналов, помогая вам оптимизировать вашу защиту.

Внимание:

  • За более подробной информацией об , пожалуйста, обращайтесь на сайт http://www.agnitum.ru/products/outpost/.

  • Также смотрите Руководство для начинающих для получения базовой информации об опасностях в Интернет.


What's New in Version 3.5?

Что нового в версии 3.5?

3.5 представляет еще более мощную защиту от Интернет-угроз наряду со значительными усовершенствованиями производительности, управления и легкости использования.

Следующие возможности представлены в версии 3.5:

  • Автосоздание правил для приложений позволяет автоматически создавать правила для наиболее известных приложений как только они впервые запрашивают доступ в сеть. Это существенно снижает количество диалоговых окон, требующих реакции пользователя.
  • приглашает вас принять участие в программе ImproveNet, нацеленной на усовершенствование качества, безопасности и функций управления ! С вашего согласия, будет анонимно собирать информацию о сетевых приложениях, установленных на вашем компьютере, чтобы затем использовать ее для расширения существующей базы данных известных приложений и создания автоматических правил доступа в сеть доступных всем пользователям.
  • 3.5 также представляет автоматическое распространение и обновление новых правил. После создания нового правила доступа на основании результатов, полученных с помощью программы ImproveNet, оно автоматически становится доступным всем пользователям через Обновление , что позволяет еще больше снизить количество всплывающих запросов программы.
  • Защита от spyware теперь еще теснее интегрирована с брандмауэром , предоставляя проверку в реальном времени всех процессов, впервые запрашивающих доступ в сеть.
  • Улучшенная система регистрации событий теперь занимает меньше системных ресурсов и предоставляет более понятные журналы. Теперь в есть возможность регистрации выборочной активности сетевых приложений с помощью определения исключений для той или иной сетевой или Интернет-активности. Система регистрации предоставляет оптимизированные настройки по умолчанию с выключенной регистрацией активности некоторых разрешающих правил.

Наряду с этими значительными улучшениями, в 3.5 существенно улучшены надежность и удобство использования брандмауэра.

Следующие проблемы были исправлены (приведены только основные):

  • Исправлено падение после диагностики подключаемых модулей.
  • Значок в системном лотке мог не появляться после загрузки.
  • Во время завершения работы мог пропускать пакеты.
  • Исправлено падение при отправке файлов минидампа.


Системные требования

Минимальные системные требования для :

  • 233 MHz Intel Pentium или совместимый процессор
  • 32 MB RAM
  • Операционная система Windows 98/2000/XP или 2003 Server
  • 30MB пространства на жестком диске.

Внимание:

  • Для нормальной работы программы не требуется специального сетевого адаптера или модема, а также специальных сетевых настроек.

  • Не следует запускать одновременно с брандмауэрами сторонних производителей - это может привести к нестабильности системы (падениям) и нарушит ее безопасность.


Как заказать

доступен для бесплатной загрузки. Вы имеете право бесплатно использовать программное обеспечение в течение испытательного срока. По завершении испытательного срока, если вы решите продолжить пользоваться программным обеспечением, вы должны будете зарегистрировать вашу копию за небольшую плату.

Для получения информации об оплате пожалуйста посетите наш сайт в Интернет: http://www.agnitum.ru/purchase/outpost/.


Интерфейс

Когда вы запускаете в первый раз, на экране отображается главное окно программы. Главное окно является основным инструментом управления брандмауэром. Через него вы можете контролировать сетевые операции компьютера и изменять настройки брандмауэра.

Главное окно брандмауэра напоминает Проводник Windows и, соответственно, его структура знакома большинству пользователей. Это делает простым для использования.

Показать главное окно

Чтобы открыть главное окно, когда оно свернуто в значок брандмауэра в системном лотке:

  1. Щелкните правой кнопкой мыши на значке брандмауэра в системном лотке.
  2. Выберите Показать.

Главное окно содержит:

Главное меню

Главное меню содержит различные команды для работы с брандмауэром.

Панель инструментов

См. раздел Панель инструментов.

Строка представлений

Отображает название узла дерева, выбранного на левой панели.

Левая панель

См. раздел Левая и информационная панели.

Информационная панель

См. раздел Левая и информационная панели.

Строка состояния

Строка состояния находится в самой нижней части главного окна брандмауэра. Она отображает текущее состояние и описания всех кнопок панели инструментов, если поднести к ним курсор мыши. Также в правом углу строки состояния высвечивается текущая политика брандмауэра.

Показать строку состояния


Панель инструментов

Панель инструментов расположена по верхнему краю главного окна. Наведя курсор на каждую из кнопок и подождав секунду, вы увидите ее предназначение. Каждая кнопка на панели управления является клавишей для быстрого доступа к какому-то пункту меню. Эти клавиши - быстрый и прямой путь к отдельным функциям, вам не придется идти через ряд пунктов меню или диалоговых окон, чтобы их вызвать.

Показать панель инструментов

Показать все кнопки панели инструментов

Кнопка | Функция | Соответствующий путь меню
 | Меняет политику брандмауэра. | Параметры > Политики
 | Запускает проверку системы на наличие spyware. | Сервис > Запустить проверку системы на наличие spyware
 | Предоставляет доступ к окнам диалога Параметры и свойствам подключаемых модулей. | Параметры > Общие
 | Меняет способ группировки записей. | Вид > Группировать по
 | Сокращает записи журнала до событий внутри данного интервала времени. | Вид > Выбрать по времени
 | Проверяет наличие доступных обновлений подключаемых модулей брандмауэра и его компонентов. | Сервис > Обновление
 | Открывает Журнал событий , отображающий историю работы брандмауэра. | Сервис > Просмотр Журнала
 | Активирует контекстную помощь брандмауэра. | Справка > Контекстная справка

Внимание:

  • Некоторые кнопки невидимы в зависимости от того, что выбрано на левой панели или на панели информации.


Левая и информационная панели

Чтобы отобразить собранную информацию доступным и простым для пользователя способом, использует две панели. Левая панель напоминает левую панель Проводника Windows. Она отображает список категорий: соединения, порты и подключаемые модули. Информационная панель предоставляет подробную информацию о каждой категории, выбранной на левой панели.

Показать панели

Как и в Проводнике Windows, любой узел со знаком плюс ( [image]) можно раскрыть, чтобы просмотреть его подкатегории. Знак минус ( [image]), предшествующий закладке, означает, что категория уже раскрыта. Нажав на знак минус, вы свернете подкатегории, что сбережет пространство экрана.

Список на левой панели и информационная панель отображают содержание следующих категорий:

Мой интернет

Выбрав эту категорию, вы увидите вводную информацию и информацию о текущей лицензии. Здесь также можно прочитать последние новости компании и получить быстрый доступ к настройкам конфигурации . Открыв эту категорию, вы увидите следующие подкатегории:

Сетевая активность

Отображает все приложения и процессы, имеющие текущие активные соединения, и подробную информацию по каждому из соединений.

Открытые порты

Отображает все приложения и процессы, у которых в данный момент открыты порты для соединения с сетью.

Разрешенные

Отображает общую статистику для всех соединений, разрешенных .

Заблокированные

Отображает общую статистику для всех соединений, заблокированных .

Сообщенные

Отображает общую статистику всех попыток приложений получить доступ к Интернету или локальной сети, о которых должен сообщать брандмауэр (по умолчанию не отображается).

Подключаемые модули

Выбрав эту категорию, вы увидите общую информацию о подключаемых модулях , последние новости по этой теме от компании , и получите быстрый доступ к настройкам кофигурации подключаемых модулей. Категорию включает в себя список установленных подключаемых модулей . По умолчанию устанавливаются следующие подключаемые модули:

Интерактивные элементы

Отображает общую статистику для сайтов, для которых была заблокированы часть интерактивных элементов на основе сценариев Java, VB, ActiveX и другие. Информацию о подключаемом модуле Интерактивные элементы см. в разделе Блокировка интерактивных элементов.

Реклама

Отображает общую статистику для всей заблокированной рекламы. Информацию о подключаемом модуле Реклама см. в разделе Блокировка рекламы.

Anti-Spyware

Отображает общую статистику всех шпионских программ, которые были обнаружены и удалены или помещены в карантин на вашем компьютере. Информацию о подключаемом модуле Anti-Spyware см. в разделе Защита от spyware.

Фильтрация почтовых вложений

Отображает общую статистику для всех почтовых вложений, которые были обезврежены и отфильтрованы на вашем компьютере. Информацию о подключаемом модуле Фильтрация почтовых вложений см. в разделе Фильтрация почтовых вложений.

Детектор атак

Отображает общую статистику всех атак на ваш компьютер из Интернета, задействованные порты и источники атак. Информацию о подключаемом модуле Детектор атак см. в разделе Предотвращение сетевых атак.

Содержимое

Отображает общую статистику веб-сайтов и страниц, которые были заблокированы этим подключаемым модулем и причины блокировки. Информацию о подключаемом модуле Содержимое см. в разделе Блокировка содержимого.

DNS

Отображает общую статистику веб-адресов, сохраненных для последущего ускоренного к ним доступа. Информацию о подключаемом модуле DNS см. в разделе Управление кэшем DNS.

Подсказка:

  • Чтобы просмотреть подробную статистику, щелкните кнопку Показать Журнал на информационной панели.


Значок в системном лотке

Еще одним элементом для контроля работы брандмауэра является значок в системном лотке. Системный лоток находится в правом нижнем углу панели задач Windows. По умолчанию значком является голубой кружок со знаком вопроса внутри: . Он появляется сразу после окончания установки брандмауэра и является одним из простейших способов получения доступа к управляющим элементам бранмауэра, настройкам и записям Журнала событий. Значок может менять свой вид в зависимости от текущей политики брандмауэра.

Щелкнув правой кнопкой мыши на значке в системном лотке, вы увидите контекстное меню.

Показать меню для значка в системном лотке

Доступны следующие команды меню:

Показать (или Скрыть)

Открывает или скрывает главное окно .

Открыть Журнал событий

Отображает Журнал событий .

Политики

Открывает подменю, в котором вы можете изменить политику брандмауэра, выбрав один из следующих возможных режимов работы: Отключить, Разрешать, Режим обучения, Блокировать, и Запрещать.

Параметры

Отображает окно Параметры.

Поверх всех окон

Если выбрано, держит текущее окно поверх всех других окон Windows.

О программе

Показывает текущую версию и перечисляет все модули в пакете и их индивидуальные версии.

Выход

Закрывает графический интерфейс и останавливает службу брандмауэра, так что больше не защиает вашу систему.

Внимание:

  • Значок в системном лотке не видим, если работает в фоновом режиме.


Режим загрузки

позволяет контролировать свое поведение при запуске системы. Для того, чтобы выбрать один из трех режимов загрузки, щелкните кнопку Параметры на панели управления. В разделе Режим загрузки вы можете выбрать один из следующих режимов:

Обычный

Режим по умолчанию. Загружает автоматически при запуске системы и отображает значок брандмауэра в системном лотке.

Фоновый

Если выбрана данная опция, будет работать в невидимом режиме, не отображая значок в системном лотке и диалоговые окна. Фоновый режим может быть полезен по двум причинам: во-первых, он позволяет сэкономить ресурсы системы, во-вторых, позволяет родителям или системному администратору блокировать нежелательный поток информации или содержимое отображаемых страниц, оставаясь при этом невидимым для пользователя.

Более подробно о работе в фоновом режиме читайте в разделе Работа в фоновом режиме.

Не загружать

Если выбран данный режим, не будет автоматически загружен при запуске системы и ваша система не будет защищена брандмауэром.


Закрытие главного окна и выключение брандмауэра

По умолчанию, когда вы сворачиваете главное окно , брандмауэр перестает отображаться на панели задач, но не прекращает работу, а сворачивается в значок в системном лотке. Вы можете изменить такое поведение брандмауэра, нажав кнопку Параметры на панели инструментов и сняв флажок Свернуть в панель задач в окне диалога.

также позволяет контролировать поведение программы при закрытии главного окна. По умолчанию, когда вы нажимаете на крестик в правом верхнем углу, вы не выключаете брандмауэр. Главное окно сворачивается в значок, который сигнализирует о том, что брандмауэр работает и обеспечивает безопасность вашей системы. Сняв флажок Свернуть при закрытии в окне диалога Параметры, вы можете сделать так, чтобы при закрытии главного окна завершал свою работу и прекращал защищать вашу систему.

Также работу брандмауэра можно остановить, выбрав команду Выход в меню Файл главного окна или же из контекстного меню значка в системном лотке.


Настройка политики брандмауэра

Один из самых полезных и важных параметров - политика брандмауэра. Политика задает, каким образом будет контролировать доступ вашего компьютера к Интернету или другой любой сети, к которой он подключен. Например, политика Блокировать предполагает особенно строгую позицию , в то время как политика Разрешать - наборот, очень мягкую.

Политики

может действоввать согласно одной из следующих политик:

Значок | Политика | Описание
 | Запрещать | Блокирует все соединения.
 | Блокировать | Блокирует все соединения кроме тех, которые были явно разрешены глобальными правилами или правилами для приложения.
 | Режим обучения | Помогает создать правила для взаимодействия приложения с сетью при первом запуске приложения.
 | Разрешать | Разрешает все соединения кроме тех, которые были явно запрещены глобальными правилами или правилами для приложения.
 | Отключить | Разрешает все соединения.

Значок, соответствующий каждому из режимов будет высвечиваться в системном лотке в качестве значка . Взглянув на значок в системном лотке, вы сразу сможете сказать, в каком режиме работает брандмауэр.

Как изменить политику брандмауэра

Чтобы изменить текущую политику брандмауэра:
  1. Щелкните кнопку Параметры на панели инструментов.
  2. Выберите закладку Политики.
  3. Выберите соотвествующий значок и щелкните OK.

Подсказка:

  • Вы также можете изменить политику брандмауэра через контекстное меню значка в системном лотке. Щелкните правой кнопкой мыши на значке, выберите Политики, и щелкните желаемую политику из меню.


Работа в Режиме обучения

После первичной установки по умолчанию назначается политика Режим обучения. Согласно этой политике, выдает сообщение каждый раз, когда доступ к сети запрашивает новое приложение или процесс, для которых еще не определены правила, либо если приложение запрашивает соединение, не охваченное текущим набором правил. Таким образом позволяет вам установить, разрешать ли данному приложению сетевой доступ к данному адресу и порту.

также позволяет упростить выбор подходящих сетевых параметров для каждого типа приложений. Вместо того, чтобы создавать новое, часто сложное правило, каждый раз при запуске нового приложения предлагает вам выбрать один из предварительно заданных наборов правил, основанных на хорошо известных приложениях. Брандмауэр даже порекомендует вам наилучший на его взгляд выбор, и если вы не уверены, какой набор следует предпочесть, просто согласитесь с рекомендацией , щелкнув OK.

Показать сообщение, выдаваемое при работе в режиме обучения

Если вы работаете в Режиме обучения, вам будет предложен один из следующих вариантов управления соединением:

Разрешить этому приложению выполнять любые действия

Для приложений, которым вы полностью доверяете. Все соединения, запрошенные данным приложением, будут разрешены, а само оно получает статус Доверенного приложения.

Запретить этому приложению выполнять какие-либо действия

Для приложений, которым вы не разрешаете доступ к сети. Все сетевые доступы для данного приложения будут блокированы, а само оно получает статус Запрещенного приложения.

Создать правило на основе стандартного

Для приложений, которые могут получить доступ к сети по определенным протоколам, через определенные порты и т.п. Используя набор предварительно заданных оптимальных установок, создает для данного приложения правило или набор правил, ограничивающих доступ к сети определенным набором портов и протоколов.

Выберите нужное приложение из ниспадающего списка и щелкните OK, чтобы создать правило на основе стандартного для данного приложения. Вы также можете создать собственное правило для данного приложения. Для этого выберите закладку Другие из ниспадающего спика и задайте нужные настройки для правила.

Это приложение будет включено в список под названием Пользовательский уровень.

Внимание:

  • Если приложение запрашивает соединение с сервером, имеющим несколько IP-адресов, автоматически обнаруживает все адреса и создает правила для всех IP-адресов данного сервера, согласно выбранному вами действию.

Разрешить однократно

Для приложений, в безопасности которых вы сомневаетесь, но хотите увидеть, что они делают при подключении к сети. Соединение будет разрешено только в этот раз. Для приложения не будет создано правило, и в следующий раз, когда это приложение будет запрашивать доступ к сети, появится то же самое окно.

Блокировать однократно

Для приложений, которым вы не доверяете, но не хотите блокировать их полностью. Данная попытка соединения будет заблокирована. Для приложения не будет создано правило, и в следующий раз, когда это приложение будет запрашивать доступ к сети, появится то же самое окно.

Внимание:

  • Режим обучения не поддерживается, когда работает в фоновом режиме, так как фоновый режим не подразумевает взаимодействия с пользователем.
  • может выполнять проверку на наличие spyware всех процессов, требующих сетевой доступ, для которых не существует правил, и отображать результат проверки в заголовке запроса Режима обучения. Подробнее см. раздел Постоянная защита от spyware.
  • Подробную информацию о создании правил для приложений см. в разделе Настройка сетевого доступа для приложений.


Работа в фоновом режиме

При работе в фоновом режиме загрузки, работает невидимо, не отображая ни значок в системном лотке, ни диалоговые окна. Это делает брандмауэр совершенно невидимым для пользователя, позволяя таким образом родителям или системному администратору незаметно для пользователя блокировать нежелательный трафик или содержимое страниц.

Еще одна причина выбрать режим фоновой загрузки - экономия системных ресурсов.

Для того, чтобы установить для фоновый режим работы, щелкните кнопку Параметры на панели управления и в группе Загрузка выберите Фоновый режим работы.

Настройка политики фонового режима работы

Поскольку политика Режима обучения не поддерживается при работе в фоновом режиме (т.к. фоновый режим не подразумевает взаимодействия с пользователем), вам нужно будет определить заранее, какая политика брандмауэра будет применяться при работе в фоновом режиме. Для того, чтобы задать политику для работы в фоновом режиме:
  1. Щелкните кнопку Параметры на панели управления и выберите закладку Политики.
  2. Выберите Режим обучения.
  3. Щелкните подчеркнутое название политики под описанием.
  4. Выберите нужную политику из ниспадающего списка в появившемся окне.
  5. Щелкните OK.


Настройка сетевого доступа для приложений

Один из основных принципов работы - предоставление доступа к сети процессам и приложениям согласно действующим правилам для приложений. Это позволяет задать гибкий доступ к сети и гарантирует, что ни один из процессов не получит неавторизованного доступа в сеть (т.е. доступа, не определенного ни одним из действующих правил).

создает список установленных приложений и автоматически устанавливает для них правила, но также предусматривает возможность модифицировать список приложений и правила для приложений вручную. Более подробную информацию см. в соответствующих разделах.


Управление списком приложений

Во время конфигурации брандмауэра обнаруживаются все установленные приложения и создаются правила для известных приложений согласно предварительно заданным настройкам. Чтобы просмотреть список обнаруженных приложений, щелкните кнопку Параметры на панели инструментов и выберите вкладку Приложения.

Согласно установкам , каждое приложение может относиться к одной из трех групп:

Запрещенные приложения

Любая сетевая активность приложений, относящихся к этой группе, блокируется. Рекомендуется добавлять в эту группу приложения, не требующие доступа в сеть Интернет, такие как текстовые редакторы, калькуляторы и т.п.

Пользовательский уровень

Этим приложениям разрешает доступ в сеть на основании стандартных и созданных вами вручную правил. Этим приложениям разрешен только определенный вид сетевой активности. Во время установки и создания конфигурации брандмауэра, автоматически обнаруживает установленные приложения и создает для них набор стандартных правил. Рекомендуется помещать большинство приложений, не обнаруженных брандмауэром, в эту группу.

Доверенные приложения

Приложениям, относящимся к этой группе, разрешена любая сетевая активность. Не рекомендуется включать сюда приложения, в полной безопасности которых вы не совсем уверены.

Вы можете изменить статус приложения и процесса, просто перетащив их в нужную категорию.

Также вы можете управлять списком приложений, добавляя приложения вручную и удаляя их. Для того, чтобы добавить приложение, щелкните кнопку Добавить. Вам будет предложено найти нужное приложение в появивишемся окне. После того, как вы добавите файл, на экране появится окно диалога Правила, в котором можно будет задать правила для нового приложения. После того, как правила будут установлены, щелкните OK и добавленное приложение появится в группе Пользовательский уровень. Более подробную информацию о том, как создавать и редактировать правила для приложений см. в разделе Настройка правил для приложений. Чтобы удалить приложение из списка, щелкните кнопку Удалить.

Внимание:

  • Вы также можете добавить приложение в список, перетащив его значок из Проводника Windows или с вашего Рабочего Стола в окно диалога Параметры > Приложения.

  • Если вы используете политику по умолчанию - Режим обучения, нет необходимости добавлять приложения в список вручную. сам предложит вам создать правила для приложения, первый раз пытающегося получить доступ в сеть.


Настройка правил для приложений

Чтобы увидеть список существующих правил для приложения, щелкните Параметры на панели инструментов, выберите вкладку Приложения, выберите приложение и щелкните Редактировать правила (или Создать правило, чтобы создать правило для Запрещенных или Доверенных приложений) в меню Изменить. На экране появится диалог Правила, в котором вы сможете изменять существующие правила для выбранного приложения и создавать новые.

Добавление нового правила

Чтобы создать новое правило, щелкните Создать в окне диалога Правила. В редакторе правил вам нужно будет задать следующие параметры:

Выберите событие для правила

Вы можете выбрать следующие критерии:

  • Где протокол
  • Где направление
  • Где удаленный адрес
  • Где удаленный порт
  • Где локальный порт
  • Где интервал времени
  • Где локальный порт совпадает с удаленным

Выберите критерий для события и задайте нужные настройки, щелкнув подчеркнутое значение в поле Описание правила.

Внимание:

  • Настройки для локального и удаленного портов доступны только, если определен протокол.

Выберите действие для правила

Вы можете выбрать следующие действия:

  • Разрешить эти данные - Разрешает это соединение.
  • Блокировать эти данные - Блокирует соединение (источник не уведомляется, создавая видимость, что пакет не достигнул адресата).
  • Сообщить - Уведомляет, когда правило сработало.
  • Запустить приложение - Когда правило сработало, запускает заданное приложение с заданными в командной строке параметрами.
  • Не регистрировать данную активность - выключает регистрацию активности для этого правила. Если флажок выбран, то при срабатывании этого правила данные не будут записываться в журнал.
  • Динамическая фильтрация - Включает "динамическую фильтрацию" для этого приложения (после того, как приложение установит соединение с удаленным сервером, все входящие данные с сервера на открытый приложением порт будут разрешены или блокированы согласно установленному правилу).
  • Игнорировать Контроль компонентов - Заставляет игнорировать Контроль компонентов во время этого соединения.

Выберите действия - соответствующие сообщения появятся в поле Описание правила. Если вы хотите, чтобы действием на событие стал запуск определенного приложения или команды, поставьте флажок в соответствующем поле и укажите приложение или команду, щелкнув на подчеркнутое значение в поле Описание правила.

Убедитесь, что в поле Описание правила не осталось неопределенных параметров. автоматически сгенерирует Имя правила на основе заданных параметров.

Щелкните OK, чтобы сохранить правило. Правило отобразится в списке. Расшифровка выбранного правила отображается в нижней части окна диалога.

Добавление правила на основе стандартного

позволяет создавать стандартные наборы правил для приложения. Например, если вы используете редко встречающийся браузер, который не был обнаружен брандмауэром во время установки, нет необходимости создавать все правила вручную. Просто щелкните кнопку Стандартные в окне диалога Правила для этой программы и выберите Browser в выпадающем меню. Все необходимые правила для данного типа приложения будут добавлены автоматически.

Изменение существующее правила

Для того, чтобы изменить уже существующее правило, выделите его в списке и щелкните Изменить. Внесите требуемые изменения, следуя приведенной выше инструкции, и щелкните OK, чтобы сохранить изменения.

Выбранные правила активны (включены) и обрабатываются брадмауэром. Уберите флажок напротив правила, если вы не хотите, чтобы выполнял это правило, но не хотите удалять его. Позже вы в любой момент можете включить правило, поставив напротив него флажок.

Правила выполняются по порядку сверху вниз. Помните, что выполняет первое по списку подходящее для соединения правило и игнорирует все последующие. Чтобы изменить порядок выполнения правил, выделите правило из списка и воспользуйтесь кнопками Вверх/Вниз.

Вы также можете копировать выделенные правила внутри приложения и удалять правила, используя соответствующие кнопки. Вы не можете копировать правила из одного приложения в другое.

Подсказка:

  • Используйте расшифровку правила в нижней части окна диалога для быстрого изменения параметров.
  • Рекомендуется сохранить существующие настройки, прежде чем вносить в них изменения.


Защита от действий вредоносных процессов

Некоторые вредоносные приложения могут внедряться в легальные программы и осуществлять свои действия от имени доверенных приложений. Например, некоторые трояны могут внедриться в компьютерную систему под видом модуля легальной программы (например, вашего браузера), и таким образом получить привелегии для соединения с компьютером хакера. Другие программы могут запустить процесс в скрытом режиме или захватить память доверенного процесса, притворившись приложением, которое вы не сочтете опасным. Применяя технологии Контроля компонентов, Контроля скрытых процессов, и Контроля памяти процессов, не допускает действия таких программ и таким образом полностью защищает вас от Троянов, spyware и других угроз. Более подробно см. соответствующие разделы.


Контроль компонентов приложения

Приложения имеют множество модулей, каждый из которых какой-либо вредоносный процесс может запрограммировать на выполнение вредоносных для вашего компьютера действий. контролирует не только действующие приложения, но и каждый их компонент. Если компонент приложения был изменен и приложение пытается установить соединение, сообщит вам об измененном компоненте и спросит разрешение на установление соединения. Отвечающая за это технология называется Контроль компонентов и ее задачей является отслеживание попыток вредоносных программ получить доступ к сети.

Изменение уровня контроля компонентов

Вы можете выбрать желаемый уровень контроля компонентов. Для этого щелкните Параметры на панели инструментов, выберите закладку Приложения, и щелкните кнопку Компоненты. В окне диалога Настройки контроля компонентов вы можете выбрать следующие уровни безопасности:

  • Обычный - будет осуществлять контроль над всеми новыми компонентами, которые проходят регистрацию перед добавлением их в папку приложения, и всеми обновленными компонентами, запоминая проверенные компоненты в собственной базе данных. Этот параметр подходит для большинства случаев и обеспечивает баланс между безопасностью и скоростью работы.
  • Максимальный - отслеживает компоненты, которые проходят регистрацию, чтобы стать частью доверенного приложения. Рекомендуется использовать этот параметр, только если вы подозреваете наличие вируса в вашей системе, так как выбор этого параметра может серьезно снизить быстродействие вашей системы.
  • Отключен - отключает контроль компонентов. Рекомендуется только при значительном замедлении скорости работы системы, падениях системы, или других ошибках, ведущих к нестабильности системы. Выключение контроля компонентов значительно снижает уровень безопасности вашей системы, т.к. больше не отслеживает компоненты каждого приложения.

Изменение уровней влияет на все приложения и их компоненты. Невозможно изменить уровень для какого-то отдельного приложения.

Внимание:

  • Не рекомендуется использовать Максимальный уровень пока вы не уверены, что вашей системе угрожает вирус, Троян или другая вредоносная программа, которую вы обнаружили.

Управление общими компонентами

Вы можете определить список компонентов, которые могут использоваться несколькими приложениями. не будет предупреждать, когда общий компонент будет запрашиваться приложением, для которого он не зарегистрирован. По умолчанию в этот список входят все системные компоненты Windows, так как они используются практически всеми приложениями Windows. В любом случае, по своему желанию вы можете изменить этот список.

Чтобы изменить список общих компонентов, щелкните Параметры на панели управления, выберите закладку Приложения, и щелкните Компоненты. Щелкните кнопку Редактировать в окне Общие компоненты, чтобы отобразить список общих компонентов. Добавьте или удалите отдельные компоненты, используя соответствующие клавиши.

Внимание:

  • После установки пакета обновлений или других обновлений программного обеспечения, которые изменяет большое число файлов в вашей системе, рекомендуется пересобрать базу данных общих компонентов, с тем чтобы знал о внесенных изменениях и новых системных компонентах. Чтобы пересобрать базу данных щелкните Пересобрать базу данных в окне Общие компоненты.

Управление компонентами приложений

также позволяет управлять компонентами, которые обнаруживает для каждого из приложений. Все зарегистрированные компоненты приложений система считает разрешенными и не выдает предупреждений, если приложение запрашивает доступ к сети, при этом используя только зарегистрированные компоненты. Исключением явлется случай, когда один или несколько зарегистрированных компонентов были изменены.

Чтобы изменить компоненты для отдельного приложения, щелкните Параметры на панели инструментов, выберите вкладку Приложения, выберите приложение из списка, и щелкните Добавить > Редактировать правила (Создать правило для разрешенных или запрещенных приложений). Затем щелкните кнопку Компоненты, чтобы увидеть список компонентов. Добавьте или удалите отдельные компоненты, используя соответствующие клавиши.


Контроль скрытых процессов

Некоторые приложения, рассчитанные на работу в сетевой среде, попадают в сеть не напрямую; они порождают дочерние процессы, которые действуют от их имени. Это позволяет таким приложениям обходить обычные брандмауэры, так как, поскольку процесс не является частью приложения, к нему не применяются ограничения, накладываемые политикой брандмауэра. Более того, процесс скрыт от пользователя, поэтому невозможно проследить, какие действия он выполняет.

С одной стороны такая технология используется стандартными приложениями (как например, Microsoft Internet Explorer) для выполнения повседневных операций (например, поиск обновленных компонентов) в наиболее дружественной пользователю манере. С другой стороны, этой технологией может воспользоваться и вредоносная программа для получения личной информации пользователя или для совершения иных несанкционированных действий.

позволяет контролировать скрытые процессы и процессы, запускаемые от имени доверенного приложения, с тем чтобы они не могли осуществлять несанкционированных действий.

Для того, чтобы включить Контроль скрытых компонентов, откройте вкладку Приложения в окне диалога Параметры и щелкните кнопку Скрытые процессы. Установите нужную политику для скрытого процесса. Доступны следующие политики:

  • Разрешить доступ - Разрешает дочернему процессу приложения получить доступ в сеть, при этом дочерний процесс наследует правила и ограничения родительской программы. Не рекомендуется выбирать этот параметр, если вы не до конца уверены, что используете абсолютно безопасное программное обеспечение. Иначе вредоносные программы смогут получить доступ в сеть и передать вашу личную информацию.
  • Блокировать доступ - Запрещает доступ в сеть всем дочерним процессам. Выбирайте этот параметр, только при крайних обстоятельствах или если вы подозреваете, что подвергаетесь атакам вредоносных программ.
  • Спрашивать - оповещает вас каждый раз, когда дочерний процесс запрашивает доступ в сеть. Рекомедуется устанавливать в большинстве случаев - вы принимаете решение, разрешать или запрещать соединение каждый раз, когда его запрашивают, и сможете следить за сетевой активностью вашей системы.

Помимо этого, вы можете разрешить ряду приложений запускать любые скрытые процессы, щелкнув кнопку Добавить и выбрав приложение из списка или указав путь к нему.


Контроль памяти процессов

Некоторые троянские кони и вирусы используют сложные методы, которые позволяют им изменять код доверенных приложений, запущенных в памяти, и обходить таким образом защиту системы и совершать злонамеренные действия. Этот прием известен также как внедрение кода.

позволяет контролировать функции, которые могут быть использованы для записи вредоносного кода в пространство памяти доверенных приложений, и таким образом не позволяет вредоносным процессам внедрять их код в доверенные приложения.

Для того, чтобы включить Контроль памяти процессов, откройте вкладку Приложения из окна диалога Параметры, щелкните Память процессов, и выберите Блокировать сетевой доступ, если память приложения была изменена другим процессом.

Чтобы разрешить отдельным процессам изменять память других приложений, щелкните Добавить и выберите нужное приложение из списка или укажите новый путь.


Настройка сетевого доступа системы

Помимо контроля доступа к сети на уровне приложений, также предоставляет продвинутым пользователям возможность контролировать трафик всей системы на всех уровнях.

С вы можете можете воспользоваться следующими преимуществами:

  • Определять правила для всех процессов, запущенных в системе - так называемые глобальные правила
  • Контролировать ICMP-трафик системы
  • Запускать брандмауэр в режиме невидимости
  • Контролировать доступ к rawsockets

Подробную информацию см. в соответствующих разделах.

Внимание:

  • Эти настройки предназначены для продвинутых пользователей. При неправильном задании они могут вызвать сбои в работе брандмауэра. В большинстве случаев вам не нужно менять эти правила или добавлять новые.


Настройка глобальных правил

Глобальные правила брандмауэра применяются ко всем процессам и приложениям на вашем компьютере, которые запрашивают доступ в сеть. Например, создав соответствующие правила, вы можете блокировать весь трафик, идущий по данному протоколу или с данного удаленного узла. Некоторые из установок глобальных правил, подобранные оптимальным образом, задает по умолчанию. Для того, чтобы просмотреть список глобальных правил, щелкните на панели инструментов кнопку Параметры, выберите вкладку Системные и щелкните Параметры в группе Глобальные правила и доступ к rawsocket.

Добавление нового правила

Для того, чтобы добавить новое правило, щелкните Добавить в окне диалога Глобальные правила. В окне редактирования правила укажите следующие параметры:

Выберите событие для правила

Вы можете выбрать следующие критерии:

  • Где протокол (с возможностью задать тип протокола для IP-протокола)
  • Где направление (с возможностью задать тип пакета для исходящего трафика)
  • Где удаленный адрес
  • Где удаленный порт
  • Где локальный адрес
  • Где локальный порт
  • Где интервал времени
  • Где локальный порт совпадает с удаленным

Выберите критерий для события и задайте нужные настройки, щелкнув на подчеркнутое значение в поле Описание правила.

Внимание:

  • Настройки для локального и удаленного портов можно изменить только для протоколов TCP или UDP.

Выберите действие для правила

Вы можете выбрать следующие действия:

  • Разрешить эти данные - Разрешает это соединение.
  • Блокировать эти данные - Блокирует соединение (источник не уведомляется, создавая видимость, что пакет не достигнул адресата).
  • Сообщить - Уведомляет, когда правило сработало.
  • Запустить приложение - Когда правило сработало, запускает заданное приложение с заданными в командной строке параметрами.
  • Пометить правило как правило с высоким приоритетом - Устанавливает правило, имеющее более высокий приоритет по сравнению с правилами для приложений (правила для приложений по умолчанию имеют наивысший приоритет).
  • Не регистрировать данную активность - выключает регистрацию активности для этого правила. Если флажок выбран, то при срабатывании этого правила данные не будут записываться в журнал.
  • Динамическая фильтрация - Включает "динамическую фильтрацию" для этого приложения (после того, как приложение установит соединение с удаленным сервером, все входящие данные с сервера на открытый приложением порт будут разрешены или блокированы согласно установленному правилу).
  • Игнорировать Контроль компонентов - Заставляет игнорировать Контроль компонентов во время этого соединения.

Выберите действия - соответствующие сообщения появятся в поле Описание правила. Если вы хотите, чтобы действием на событие стал запуск определенного приложения или команды, поставьте флажок в соответствующем поле и укажите приложение или команду, нажав на подчеркнутое значение в поле Описание правила.

Убедитесь, что в поле Описание правила не осталось неопределенных параметров. автоматически сгенерирует Имя правила на основе заданных параметров.

Щелкните OK, чтобы сохранить правило. Правило отобразится в списке.

Изменение существующее правила

Для того, чтобы изменить уже существующее правило, выделите его в списке и щелкните кнопку Изменить. Внесите требуемые изменения, следуя приведенной выше инструкции, и щелкните OK, чтобы сохранить изменения.

Выбранные правила активны (включены) и обрабатываются брадмауэром. Уберите флажок напротив правила, если вы не хотите, чтобы выполнял это правило, но не хотите удалять его. Позже вы в любой момент можете включить правило, поставив напротив него флажок.

Правила выполняются по порядку сверху вниз. Помните, что выполняет первое по списку подходящее для соединения правило и игнорирует все последующие. Чтобы изменить порядок выполнения правил, выделите правило из списка и воспользуйтесь кнопками Вверх/Вниз.

Вы также можете скопировать выделенное правило и удалять правила, используя соответствующие кнопки. Не рекомендуется удалять встроенные глобальные правила.

Подсказка:

  • Рекомендуется сохранить существующие настройки, прежде чем вносить в них изменения.


Контроль активности протокола ICMP

Протокол контроля сообщений Интернет (Internet Control Message Protocol, ICMP) отправляет предупреждающие сообщения и сообщения об ошибках находящимся в сети компьютерам. позволяет вам указать типы и направления разрешенных сообщений ICMP.

Чтобы задать настройки ICMP, щелкните Параметры на панели инструментов, выберите вкладку Системные и щелкните Параметры в группе ICMP. В окне диалога Настройки ICMP приводится список основных типов ICMP-сообщений; вы можете разрешить входящие или исходящие сообщения, поставив напротив соответствующий флажок. Если флажка нет, данное соединение блокируется.

Чтобы восстановить настройки ICMP по умолчанию, щелкните кнопку По умолчанию.

Внимание:

  • Не рекомендуется менять настройки ICMP, если вы не уверены во вносимых изменениях.

  • О различных типах ICMP-сообщений читайте в Приложении Б: Типы сообщений ICMP руководства пользователя .


Работа в режиме невидимости

Режим невидимости позволяет вам определить, будет ли ваш компьютер отвечать на запросы к портам или же всегда будет блокировать их, становясь таким образом невидимым для хакеров.

Обычно, когда ваш компьютер получает запрос о соединении с портом, не используемым для входящих и исходящих соединений, он сообщает, что порт не используется, посылая уведомление "порт недоступен". В режиме невидимости ваш компьютер не ответит, как если бы он был не включен или не подключен к сети. В этом случае, пакеты, отправленные к неиспользуемому порту, будут игнорироваться брандмауэром без отправки источнику уведомления ICMP или TCP.

Для того, чтобы установить режим невидимости для брандмауэра, щелкните Параметры на панели управления, выберите вкладку Системные и в группе Режим работы выберите Режим невидимости.

Внимание:

  • Рекомендуется работать в режиме невидимости, если у вас нет особых причин отказаться от него.


Контроль доступа к rawsockets

Некоторые приложения могут получать доступ в сеть с помощью обращений напрямую к низкоуровневым сокетам (socket), также известным как rawsockets. Эти обращения не регулируются обычными протоколами и правилами для приложений, и поэтому могут служить потайным ходом для вредоносных приложений или способом для получения безконтрольного доступа в сеть.

Чтобы улучшить защиту вашей системы, позволяет вам контролировать доступ к rawsockets. Вы можете указать, каким приложениям разрешен доступ к rawsockets, а каким нет. Для того, чтобы создать список приложений, которым разрешен доступ к rawsockets, щелкните Параметры на панели управления, выберите вкладку Системные и в группе Глобальные правила и доступ к rawsocket щелкните кнопку Rawsockets. Щелкните кнопку Добавить и выберите приложение, которому хотите разрешить доступ к rawsockets.

Если вы хотите, чтобы уведомлял вас каждый раз, когда неизвестное приложение пытается получить доступ к rawsockets, отметьте соответствующий флажок.

Внимание:

  • Помните, что, будучи добавленным в этот список, приложение получает неограниченный сетевой доступ.


Настройки локальной сети

Основная разница между локальной сетью (LAN) и Интернет состоит в различном уровне доверия к той или иной сети. Локальная сеть, используемая в домашних условиях или в офисе, как правило состоит из "дружественных" компьютеров, которые обычно принадлежат членам семьи или коллегам.

позволяет вам обнаружить сети, к которым принадлежит ваш компьютер, и установить свой уровень доступа для каждой из сетей.


Обнаружение локальной сети

Обычно настройки локальной сети вашего компьютера устанавливаются автоматически во время установки . Однако если вы выбрали установку вручную или/и удалили все обнаруженные сети, вам придется заново обнаруживать локальные сети для того, чтобы нормально общаться с остальными компьютерами.

Чтобы просмотреть список сетей, в которые входит ваш компьютер, щелкните кнопку Параметры на панели управления, выберите вкладку Системные и щелкните Параметры в группе Настройки локальной сети.

Автоматическое обнаружение сети локальной сети

В диалоге Настройки локальной сети щелкните кнопку Найти и автоматически обнаружит сети, в которые входит ваш компьютер и выдаст список их IP-адресов с указанием уровней доступа по умолчанию. Задайте нужный уровень доступа для каждой из сетей.

Для того, чтобы мог автоматически находить новые сети и вам не пришось бы добавлять их вручную, поставьте флажок напротив Находить новые настройки сети автоматически и щелкните OK, чтобы сохранить настройки.

Добавление сетевого адреса вручную

В случае, если вы хотите добавить в список новую сеть или удаленный узел с тем, чтобы задать особый уровень доступа, или, если по какой-либо причине не обнаружил вашу сеть автоматически, вы можете сделать это вручную.

Для этого в диалоге Настройки локальной сети щелкните кнопку Добавить и в появившемся диалоге Сетевой адрес задайте формат, который вы будете использовать для ввода адреса. Доступны следующие варианты:

  • Имя домена. Например, http://www.agnitum.ru. В этом случае требуется подключение к сети Интернет, поскольку IP-адреса разрешаются через Интернет. IP-адрес запоминается наряду с заданным вами именем домена, и именно этот IP-адрес будет использоваться в большинстве случаев.
  • IP-адрес. Например, 216.12.219.12
  • Диапазон IP-адресов (маска подсети). Например, 216.12.219.1 - 216.12.219.255

Введите требуемый адрес в том формате, который вы выбрали (можно использовать маски) и щелкните Добавить. Подобным образом вы можете последовательно добавить несколько адресов. Щелкните OK, чтобы они добавились в список в диалоге Настройки локальной сети. Задайте нужный уровень доступа для каждой из сетей и щелкните OK для сохранения настроек.

Удаление адреса из списка

Вы можете удалить из списка выбранный адрес или сеть, щелкнув кнопку Удалить. Удаление адреса из списка аналогично заданию для этого адреса уровня Ограниченный доступ к LAN (т.е. нужно снятию флажков NetBIOS и Доверенные).

Внимание:

  • Более подробно о настройках уровней доступа к сети LAN читайте в разделе Настройка уровней доступа для локальной сети (LAN).


Настройка уровней доступа для локальной сети (LAN)

Каждый компьютер в локальной сети может получить один из трех уровней доступа к вашему компьютеру:

  • NetBIOS. Разрешает разделение доступа к файлам и принтерам между компьютером из локальной сети и вашим компьютером. Чтобы установить этот уровень, отметьте соответствующий флажок NetBIOS для этого адреса.
  • Доверенные. Все соединения к и из этой сети разрешены. Чтобы установить этот уровень, отметьте флажок Доверенные для этого адреса.
  • Ограниченный доступ к LAN. NetBIOS соединения блокируются, все остальные соединения обрабатываются согласно глобальным правилам и правилам для приложений. Чтобы установить этот уровень, уберите оба флажка NetBIOS и Доверенные для этого адреса.

Важно помнить, что узел, относящийся к числу Доверенных, имеет наивысший приоритет. С таким узлом могут соединяться даже запрещенные приложения. Рекомендуется помещать в список Доверенных только СОВЕРШЕННО БЕЗОПАСНЫЕ компьютеры. Если вам нужно только разделение доступа к файлам и принтерам, лучше использовать уровень NetBIOS, а не Доверенные.

Если вы не хотите засорять журналы информацией о широковещательных пакетах NetBIOS, вы можете выключить регистрацию этих данных для каждого обнаруженного узла или сети. Выберите адрес в списке и снимите флажок Регистрировать широковещательные сообщения NetBIOS для выбранного узла или сети в группе Информация. Это позволит более наглядно представлять информацию в Журнале событий и может улучшить производительность компьютера.

Внимание:

  • Широковещательные пакеты NetBIOS - это входящие или исходящие UDP-пакеты с адресом отправителя, принадлежащим выбранной подсети, и отправленные на адрес 255.255.255.255 с 137 или 138 порта на этот же самый порт. Такие пакеты, например, используются клиентскими компьютерами для оповещения о своем присутствии в сети.
  • Пожалуйста, обратите внимание, что подключаемые модули работают вне зависимости от установленного уровня доступа для сети. Например, если вы добавили к Доверенным сетевым адресам http://www.agnitum.ru, подключаемые модули будут продолжать блокировать баннеры, интерактивные элементы и пр. для этого адреса независимо от того, какой уровень доступа для него установлен.


Защита настроек брандмауэра

позволяет вам защитить указанные вами настройки от несанкционированных изменений. Защищенные паролем, настройки брандмауэра не могут быть изменены кем-либо кроме вас. Например, вы можете блокировать доступ к нежелательным сайтам для ваших детей и быть уверены, что ваши настройки не будут изменены.

Установка пароля

Для того, чтобы установить пароль, щелкните кнопку Параметры на панели инструментов и в группе Защита паролем выберите Включить. Задайте пароль, щелкните OK и подтвердите введенный пароль в появившемся окне. Щелкните еще раз OK, чтобы сохранить пароль - он начнет защищать ваши настройки сразу после закрытия окна диалога Параметры. Начиная с этого момента всякому, кто захочет получить доступ к настройкам брандмауэра или созданию новой конфигурации, будет выдано сообщение с просьбой ввести пароль.

Изменение пароля

Для того, чтобы изменить пароль, щелкните кнопку Параметры на панели инструментов, введите пароль и в группе Защита паролем щелкните кнопку Задать пароль. Задайте и подтвердите новый пароль и щелкните OK. Изменения вступят в силу сразу после закрытия окна диалога Параметры.

Снятие пароля

Для того, чтобы снять пароль, щелкните Параметры на панели инструментов, введите пароль и в группе Защита паролем щелкните кнопку Выключить. После того, как вы щелкните OK, все настройки брандмауэра станут доступны любому.

По умолчанию пароль защищает от изменений только ваши настройки конфигурации, но вы также можете защищать Журнал событий от запуска и службу от остановки, отметив соответствующие флажки в окне диалога. Это может понадобиться, если вы хотите защитить историю сетевой системы от просмотров несанкционированными пользователями или предотвратить выключение установленной вами защиты и ограничений. Это особенно полезно для родителей, которые хотят контролировать доступ своих детей к Интернету и работодателей, желающих ограничить доступ к сети для своих работников.

Внимание:

  • Пожалуйста запомните ваш пароль. В случае, если вы забудете пароль, вам придется переустанавливать .


Подключаемые модули

Помимо основных функций , его функциональность может быть расширена с помощью технологии подключаемых модулей. Подключаемый модуль - это специальный модуль, который может работать параллельно с основной программой, выполняя ряд независимых действий и тем самым расширяя функциональность программы. Такая стратегия очень удобна, так как позволяет отключать ненужные модули, не останавливая при этом работу брандмауэра и не подвергая риску безопасность вашего компьютера. Кроме того, для увеличения возможностей вы можете легко добавлять к нему подключаемые модули, созданные сторонней компанией.

Чтобы посмотреть список доступных подключаемых модулей, откройте категорию Подключаемые модули на левой панели. По умолчанию устанавливаются следующие модули:

  • Интерактивные элементы. Позволяет блокировать и управлять интерактивным содержимым веб-страниц (ActiveX, сценарии, аплеты и т.п.).
  • Реклама. Блокирует баннеры и рекламные объявления, увеличивая скорость просмотра веб-страниц.
  • Anti-Spyware. Обнаруживает, оповещает и удаляет все известные spyware-программы с вашего компьютера.
  • Фильтрация почтовых вложений. Сканирует, оповещает и фильтрует почтовые вложения, не позволяя потенциально опасным файлам навредить вашей системе.
  • Детектор атак. Обнаруживает, оповещает и отражает различные внешние атаки.
  • Содержимое. Блокирует веб-страницы с нежелательным или нецензурным содержанием.
  • DNS. Запоминает наиболее часто используемые адреса DNS для ускорения доступа к веб-страницам.

Вы можете менять поведение подключаемых модулей, меняя их установки. Для того, чтобы получить доступ к настройкам, щелкните правой кнопкой мыши на нужном модуле в левой панели и выберите Свойства. Более подробную информацию о функциях каждого из подключаемых модулей см. в соответствующих разделах.

Добавление и удаление подключаемых модулей

Вы можете также воспользоваться возможностью установки подключаемых модулей сторонних компаний. Информацию о доступных подключамых модулях можно найти здесь: http://www.agnitum.ru/products/outpost/plugins3rd.html.

Для того, чтобы добавить дополнительный подключаемый модуль, щелкните кнопку Параметры на панели инструментов и выберите вкладку Подключаемые модули. Щелкните Добавить и укажите путь к файлу подключаемого модуля. После добавления новый модуль появится в списке подключаемых модулей. Чтобы запустить модуль, щелкните кнопку Запустить. Кнопка Параметры открывает диалог, в котором описываются свойства модуля.

Для того, чтобы остановить работу подключаемого модуля или удалить его из интерфейса , выберите нужный модуль в списке и щелкните соответствующую кнопку.

Внимание:

  • Подключаемые модули работают независимо друг от друга и от главного модуля . Устанавливаемые вами глобальные правила, правила для приложений или настройки LAN (например, настройка Доверенные) не повлияют на работу ни одного из подключаемых модулей.

  • Если вы заинтересованы в разработке подключаемых модулей, пожалуйста посетите страницу http://www.agnitum.ru/products/outpost/developers.html, где вы сможете найти примеры, руководства и форум разработчиков.


Блокировка интерактивных элементов

Современные веб-сайты используют различные технологии, позволяющие улучшить их функциональность и увеличить уровень интерактивности с помощью т.н. встраиваимых интерактивных элементов. Среди таких технологий ActiveX, Flash, сценарии Java, сценарии VB и другие. И хотя эти технологии разрабатывались с тем, чтобы облегчить жизнь пользователей, не менее успешно используются они и хакерами, чтобы получить доступ к вашему компьютеру, и таким образом ставят под угрозу безопасность вашей системы. Кроме того, многие сайты используют их для отображения назойливой рекламы, которая значительно снижает скорость загрузки веб-страниц.

Подключаемый модуль Интерактивные элементы контролирует работу интерактивных элементов, встроенных в загружаемые веб-страницы или входящие почтовые сообщения и позволяет вам разрешать или блокировать любые из них. Возможен контроль над следущими элементами: ActiveX, приложения Java, программы на основе сценариев Java и Visual Basic, cookies, всплывающие окна, сценарии ActiveX, внешние интерактивные элементы, referrers, скрытые фреймы, GIF- и flash-анимации.

Глобальные настройки фильтрации

Вы можете настроить управление интерактивными элементами независимо для почтовых сообщений, новостей и веб-страниц. Выберите подключаемый модуль Интерактивные элементы на левой панели, щелкните на нем правой кнопкой мыши и выберите Свойства. Выберите одну из вкладок Почта и новости либо Веб-страницы и элемент, настройки для которого вы хотите указать. В правой части окна отобразится описание элемента и настройки для него. По умолчанию, разрешено использование всех интерактивных элементов для всех веб-страниц. Для того, чтобы разрешить или запретить выполнение отдельного активного компонента, выберите один из доступных параметров:

  • Разрешено. Элементы данного типа всегда разрешены.
  • Запрос. запрашивает вас, прежде чем разрешить элемент данного типа.
  • Запрещено. Элементы данного типа всегда запрещены.

Щелкните OK, чтобы сохранить настройки.

Внимание:

  • Параметр Запрос недоступен для скрытых фреймов, GIF-анимаций и внешних интерактивных элементов.

  • Некоторые сайты требуют активации всех или некоторых из интерактивных элементов страниц для корректного отображения содержимого или даже работы сайта. Если задать слишком много ограничений для всех сайтов, можно столкнуться со следующими проблемами: не будут видны изображения, веб-страница не отображается вовсе, веб-страница отображается некорректно или не работают нужные службы на странице. Если это происходит лишь с небольшим числом сайтов, просто измените настройки подключаемого модуля для этих сайтов, добавив их в список исключений (см. ниже). В противном случае, вам следует установить более мягкую политику, чем заданная по умолчанию.

Настройки фильтрации для отдельных веб-страниц

Чтобы установить свою политику управления интерактивными элементами для какого-то отдельного сайта, выберите подключаемый модуль Интерактивные элементы на левой панели, щелкните на нем правой кнопкой мыши и выберите Свойства. Откройте вкладку Исключения, щелкните Добавить и задайте адрес сайта, для которого вы хотите персонифицировать настройки. После того как вы щелкните OK, на экране появится окно Настройки для узла для этого сайта, в котором вы сможете указать желаемые параметры для обработки интерактивных элементов сайта. Всем интерактивным элементам добавляемого сайта сразу же задаются значения по умолчанию. Настройки здесь практически идентичны вышеописанным глобальным настройкам, и доступны следующие параметры:

  • Разрешено. Элементы данного типа с данного сайта всегда разрешены.
  • Запрещено. Элементы данного типа с данного сайта всегда запрещены.
  • Наследовать. Поведение элемента определяется глобальными настройками (в скобках).

Обратите внимание на то, что параметры, наследующие глобальные значения, отображены серым цветом; параметры, отличные от параметров по умолчанию, отображены синим. Сделайте свой выбор (используйте кнопку Восстановить, если вы хотите вернуть всем параметрма их глобальные значения) и щелкните OK, чтобы сохранить их.

Позже вы сможете отредактировать настройки интерактивных элементов, выбрав сайт из списка и щелкнув Свойства.

Если вы хотите настраивать конфигурацию для каждого сайта, который вы посещаете, индивидуально, выберите Добавлять web-сайты в список исключений при первом посещении, и каждый раз при первом посещении страницы будет отображать окно диалога Мастер Правил Узлов. Выберите один из параметров Разрешить/Запретить все типы интерактивных узлов для данного сайта и сайт будет немедленно добавлен в список исключений с соответствующими настройками. Если вы выберите Редактировать правила для узла, на экране отобразится окно диалога Настройки для узла, в котором по схеме, описанной выше, вы сможете задать свои параметры для управления интерактивными элементами.

Внимание:

  • Чтобы просмотреть список элементов, заблокированных подключаемым модулем Интерактивные элементы, выделите модуль на левой панели и щелкните кнопку Показать Журнал на информационной панели. Журнал событий отобразит события для модуля Интерактивные элементы. Более подробно о Журнале событий см. в разделе Слежение за сетевой активностью.


Блокировка рекламы

Все больше и больше интернет сайтов сегодня наполняются рекламой, иногда очень назойливой, изображениями спорного содержания, заполняющими страницы и замедляющими их загрузку. Последнее не является проблемой, если вы используете быстрое соединение, но часто хочется бороздить просторы Интернета, не отвлекаясь на мигающую и двигающуюся по экрану рекламу.

Подключаемый модуль Реклама позволяет блокировать определенные рекламные объявления и баннеры, увеличивая таким образом скорость загрузки веб-страниц. Объявления могут блокироваться по двум критериям: по ключевым словам, найденным в содержимом загружаемой страницы, или по размеру рекламного изображения.

Блокировка по ключевым словам

Подключаемый модуль Реклама блокирует объявления, основываясь на ключевых словах, найденных в HTML-тегах "IMG SRC=" и "A HREF=" рекламного баннера. Если URL баннера содержит хотя бы одно из заданных ключевых слов, баннер заменяется текстом "[AD]" или прозрачным GIF-изображением такого же размера.

Для того, чтобы включить блокировку по ключевым словам, откройте свойства подключаемого модуля, щелкнув на нем в левой панели правой кнопкой мыши и выбрав Свойства, и отметьте флажком Блокировать объявления, содержащие указанные ключевые слова на вкладке Ключевые слова.

Также вы можете задать список ключевых слов для блокировки рекламы. Для того, чтобы добавить слово в список блокировки, введите его в предназначенное для этого текстовое поле и щелкните Добавить. Слово появится в списке и реклама, содержащая это слово, не будет отображаться в вашем веб-браузере. Вы также можете редактировать и удалять ключевые слова из списка. Чтобы вернуть настройки по умолчанию, щелкните кнопку По умолчанию.

Блокировка рекламы по размеру изображений

Подключаемый модуль Реклама блокирует рекламные изображения, основываясь на их размере, заданном в HTML-теге "A". Если размер баннера соответствует одному из заданных в списке, он заменяется текстом "[AD]" или прозрачным GIF-изображением такого же размера.

Для того, чобы включить блокировку по размеру изображений, откройте свойства подключаемого модуля, щелкнув на нем в левой панели правой кнопкой мыши и выбрав Свойства, и отметьте флажком Блокировать изображения по размеру на вкладке Размеры изображений.

По умолчанию блокируется реклама некоторых стандартных размеров. Чтобы заблокировать рекламный баннер определенного размера, задайте его ширину и высоту в соответствующих полях и щелкните Добавить. Запись для этого размера появится в списке и объявления такого размера не будут отображаться в вашем веб-браузере. Вы также можете редактировать и удалять размеры из списка. Чтобы вернуть настройки по умолчанию, щелкните кнопку По умолчанию.

Варианты замещения рекламы

Подключаемый модуль Рекмала дает возможность выбрать, чем будет замещена заблокированная реклама: текстом "[AD]" или прозрачным фоном такого же размера. Чтобы настроить этот параметр, выберите вкладку Разное в окне свойств модуля и выберите нужный вариант в группе Замена рекламных изображений.

Обратите внимание на то, что хотя замещение рекламных баннеров прозрачным фоном делает навигацию намного удобнее, т.к. убирает лишнюю графику, иногда имеет смысл предпочесть замену баннеров текстовыми ссылками, потому что в этом случае у вас сохранится возможность переходить по ним.

Доверенные сайты

Если вы столкнулись с проблемами при просмотре отдельных сайтов, например, большинство изображений на сайте заблокировано, можно добавить этот сайт в список доверенных, и подключаемый модуль не будет блокировать на нем графику. Для того, чтобы добавить сайт в список, щелкните Редактировать в группе Доверенные сайты на вкладке Разное и введите название сайта. Щелкните Добавить, чтобы добавить сайт в список и OK, чтобы закрыть окно. Брандмауэр не будет блокировать рекламу и баннеры с доверенных сайтов.

Блокировка рекламных объектов

Современные рекламные баннеры включают в себя не только графическую часть, но и различные интерактивные элементы. Самый простой пример - анимированные изображения Macromedia Flash, широко используемые практически на всех сайтах. Такая реклама потребляет гораздо больше системных ресурсов и требует большей пропускной способности сети, чем традиционные баннеры, и не отсекается большинством стандартных систем по блокировке рекламы.

может также блокировать рекламные объявления, выполненные в виде интерактивных элементов, сохраняя таким образом ваши системные ресурсы и экономя сетевой трафик. Чтобы включить блокировку рекламы, поставьте флажок в графе Блокировать интерактивные рекламные объявления на вкладке Разное свойств модуля.

Экспорт и импорт настроек подключаемого модуля

Вы можете экспортировать настройки подключаемого модуля в файл и загрузить их обратно из предварительно созданного файла. Эта возможность может быть полезна, если вы хотите быстро переключаться между различными настройками модуля. Например, одна конфигурация может блокировать доступ к содержимому "сайтов для взрослых", другая - блокировать рекламные объявления, третья - еще какое-нибудь нежелательное содержимое. Также это поможет перенести настройки с одного компьютера на другой и упростить начальную настройку на новых компьютерах.

Для того, чтобы экспортировать или импортировать настройки подключаемого модуля, щелкните соответствующую кнопку на вкладке Экспорт/Импорт свойств модуля. Введите имя файла и щелкните OK.

Вы также можете загрузить полный список ключевых слов для блокировки рекламы (AGNIS list), перейдя по приведенной ссылке на форум.

Внимание:

  • Рекламные баннеры блокируются согласно установленным вами настройкам. Поэтому, если ваши настройки слишком строги (например, если вы добавили слово "image" в список ключевых слов), некоторые легальные изображения также могут быть блокированы. В то же время некоторая реклама не блокируется с помощью настроек, заданных по умолчанию.

  • Чтобы просмотреть элементы, заблокированные подключаемым модулем Реклама, выберите модуль на левой панели и щелкните кнопку Показать Журнал на информационной панели. Журнал событий отобразит события для подключаемого модуля Реклама. Более подробно о Журнале событий см. в разделе Слежение за сетевой активностью.


Защита от spyware

Spyware (или шпионское программное обеспечение) является растущей проблемой, затрагивающей множество пользователей персональных компьютеров. Все чаще пользователи подвергаются атакам вредоносных программ (как правило, не зная об этом), которые собирают информацию о статистике посещений веб-страниц, установленных на компьютере приложениях и другие личные данные, которые затем отсылаются третьей стороне, spyware отслеживает действия пользователя без его на то согласия. Spyware могут изменять тексты почтовых сообщений, модифицировать содержимое файлов на жестком диске, показывать назойливые рекламные объявления, менять адрес домашней страницы вашего браузера. И, наконец, если всего вышеперечисленного оказалось недостаточно, резидентное spyware отнимает значительное количество системных ресурсов, иногда существенно снижая скорость работы вашего компьютера.

Подключаемый модуль Anti-Spyware создан для того, чтобы предупредить нежелательные и несанкционированные действия шпионских программ, избавиться от назойливой рекламы и защитить ваши личные данные от похищения шпионскими программами и Троянами.

Внимание:

  • Более подробную информацию об угрозах spyware вы найдете в Руководстве пользователя .


Проверка системы

Если вы не осуществили проверку системы во время установки , рекомендуется выполнить полное сканирование сразу после завершения установки, чтобы проверить систему на наличие в ней spyware. Чтобы это сделать, запустите Spyware-сканер, выделив подключаемый модуль Anti-Spyware на левой панели и щелкнув кнопку Запустить проверку системы на информационной панели. Мастер поможет вам задать нужные настройки для проверки системы и проведет вас через весь процесс сканирования.

Выберите тип проверки

Первый шаг - выбор типа сканирования системы. Вы можете выбрать одну из следующих проверок:

  • Быстрая проверка системы. Во время быстрой проверки выполнит быстрое сканирование системы, проверив ее уязвимые места (такие как запущенные в памяти процессы, уязвимые ключи реестра, уязвимые файлы и папки). Рекомендуется для ежедневного использования.
  • Полная проверка системы. Полная проверка выполняет глубокий анализ реестра и файловой системы, а также еще несколько проверок (проверка запущенные в памяти процессы, сканирование cookies, сканирование параметров автозапуска). Используйте эту проверку для первого сканирования системы на наличие spyware или когда вам необходим всесторонний анализ. Операция может занять значительное время.
  • Выборочная проверка. Выборочная проверка позволяет проверить только указанные местоположения. Помимо параметров, описанных выше, вы также можете выбрать, какие именно объекты должны быть проверены в вашей файловой системе.

Выберите нужный тип проверки и щелкните Далее. Если вы выбрали Выборочную проверку, следующий шаг - Выбор объектов проверки - предложит вам выбрать, какие конкретно объекты вы хотите сканировать. Щелкните Выбрать папки, чтобы выбрать определенные диски, папки и файлы для проверки. В окнe Выбор папок, укажите путь к нужным дискам, папкам и файлам. Если вы хотите проверить определенные файлы, поставьте флажок напротив Отображать файлы, чтобы отобразился также список файлов. Щелкните OK после того, как сделаете выбор.

После задания объектов для проверки, щелкните Далее, чтобы начать процесс сканирования.

Выполнение проверки

После того, как вы щелкните кнопку Далее, программа начнет сканирование выбранных объектов. В окне состояния отбражаются общее число проверенных объектов и число обнаруженных потенциально опасных объектов.

Процесс сканирования может быть запущен в фоновом режиме. Если вы хотите работать с во время осуществления проверки, щелкните кнопку Фоновый режим и сканер будет свернут в индикатор процесса на информационной панели. Щелкните Показать мастер, чтобы снова отобразить окно.

Вы можете остановить процесс сканирования и перейти к результатам в любое время, щелкнув Отмена.

По завершении проверки список обнаруженных объектов (если таковые были) отображается автоматически. Если ваша система чистая, т.е. никаких подозрительных объектов обнаружено не было, отобразятся результаты проверки.

Удаление обнаруженных объектов

Шаг Выбор объектов для удаления позволяет вам просмотреть обнаруженное spyware и удалить его из вашей системы. Для каждого объекта отображается степень риска и категория, к которой он был отнесен. Также отображается число совпадений сигнатур - количество мест на вашем компьютере, где был обнаружен объект. Щелкните два раза мышью на объекте, чтобы просмотреть детали.

Выберите объекты, которые вы хотите удалить, и щелкните Далее. Выбранное программное обеспечение будет удалено из памяти и тех мест, где оно зарегистрировано, и будет помещено в карантин, так что при желании вы в любое время сможете восстановить его или удалить из системы полностью. Помещенное в карантин программное обеспечение не может нанести вреда вашей системе, но информация о нем хранится в системе, чтобы при необходимости иметь возможность восстановить программу. Более подробно об использовании карантина для spyware см. ниже.

Программное обеспечение, которое вы решили не удалять, будет оставлено без изменений и продолжит работу в вашей системе.

Подсказка:

  • Если вам известно, что некоторые из обнаруженных программ не являются spyware, а являются законными программами, и вы не хотите, чтобы обращался с ними как со spyware (например, хотите, чтобы в каком-то бесплатном программном продукте отображалась реклама), вы можете добавить эти программы в список исключений. игнорирует программы из списка и не будет отображать предупреждения, обнаружив их работу. Также эти программы не будут отображены в списке обнаруженного spyware. Чтобы добавить программу в список исключений, щелкните на ней правой кнопкой мыши и выберите Добавить в список исключений. Запись для этой программы будет удалена из списка обнаруженного spyware.
    • Позже вы сможете удалить программу из списка исключений, воспользовавшись кнопкой Редактировать на вкладке Общие свойств подключаемого модуля.

Важно:

  • В действительности, cookie не являются spyware, но могут быть использованы для кражи информации с вашего компьютера. Шпионское программное обеспечение, установленное на вашем компьютере, может записывать информацию в файлы cookie и при посещении соответствующих страниц информация может быть переправлена третьему лицу.

Просмотр результатов сканирования

На последнем шаге мастер отображает отчет по результатам сканирования, из которого вы можете узнать число обнаруженных, удаленных и помещенных в карантин spyware-объектов, а также другую информацию о сканировании системы. После просмотра результатов щелкните Готово, чтобы завершить работу мастера.

Внимание:

  • Для того, чтобы просмотреть объекты, обнаруженные и удаленные модулем Anti-Spyware, выберите модуль на левой панели и щелкните кнопку Показать Журнал на информационной панели. Журнал событий отобразит события для модуля Anti-Spyware. Более подробно о Журнале событий см. в разделе Слежение за сетевой активностью.


Постоянная защита от spyware

Подключаемый модуль Anti-Spyware обеспечивает постоянную защиту от spyware в реальном времени. Когда постоянная защита включена, все уязвимые объекты системы находятся под постоянным наблюдением, чтобы гарантировать, что spyware будет обнаружено прежде чем сумеет нанести вред.

Чтобы включить постоянную защиту, откройте диалог свойств модуля Anti-Spyware, щелкнув на нем правой кнопкой мыши и выбрав закладку Свойства, и поставьте флажок Включить постоянную защиту. Вы можете менять поведение модуля по обнаружению spyware, изменяя настройки этого диалога. Доступны следующие действия:

  • Запрашивать пользователя. При обнаружении подозрительных программ на экране появится окно диалога, спрашивающее пользователя о дальнейшем действии.

    Показать окно оповещения

    Чтобы удалить все обнаруженное spyware с вашего компьютера, щелкните Удалить все. При желании вы можете просмотреть список найденных spyware-программ и удалить их выборочно. Для этого щелкните Показать, выберите программу в списке и щелкните Удалить рядом с ней. Если вы считаете некоторые из обнаруженных программ легальными, убеждены, что это не шпионское ПО, и не хотите, чтобы обходился с ними как со spyware (например, если вы хотите видеть рекламу, размещенную в каком-то бесплатном программном продукте), вы можете добавить эти программы в список исключений, щелкнув В исключения рядом с именем программ. Программы из списка исключений будут игнорироваться во время проверки и предупреждения об обнаружении активности этих программ не будут выводиться на экран. Позже вы сможете удалить программу из списка исключений, воспользовавшись кнопкой Редактировать на вкладке Общие свойств модуля. Чтобы добавить в список исключений все обнаруженные spyware-программы, щелкните Все в исключения.

  • Удалять автоматически. При обнаружении подозрительной программы, соответствующий объект будет удален автоматически. Не рекомендуется выбирать этот параметр, так как вы можете удалить и часть легитимных программ.

    В этом режиме вы можете включить визуальные и звуковые оповещения при обнаружении spyware. Для этого щелкните кнопку Оповещения и проставьте соответствующие флажки. будет показывать визуальное оповещение и проигрывать специальный звуковой файл каждый раз, когда обнаруживает и удаляет spyware. Это позволяет узнать, какие запущенные программы или посещаемые веб-страницы подвергают вас риску.

Вы также можете выбрать автоматическую проверку процессов, требующих сетевой доступ, для которых не существует правил. Выберите флажок Проверять процессы, запрашивающие сетевой доступ и вы будете видеть результат проверки на наличие spyware в заголовке запроса Режима обучения каждый раз, когда какое-либо приложение запрашивает соединение в первый раз. Таким образом, уровень защиты будет высоким даже в случае выключенной из соображений производительности постоянной защиты.

Внимание:

  • Для того, чтобы просмотреть, какие объекты были обнаружены и удалены модулем Anti-Spyware, выделите модуль на левой панели и щелкните кнопку Показать Журнал на информационной панели. Журнал событий отобразит события для модуля Anti-Spyware. Более подробную информацию о Журнале событий см. в разделе Слежение за сетевой активностью.


Карантин spyware

Обнаруженное spyware можно не удалять полностью, а поместить в отдельное изолированное место – "карантин" - чтобы в дальнейшем иметь возможность восстановить его в случае необходимости (если вы решите, что удаленный объект не наносил вреда системе). Объекты, помещенные в карантин, не могут нанести вреда вашему компьютеру.

Для того, чтобы помещал все удаленные объекты в карантин, откройте свойства модуля и поставьте флажок Помещать в карантин перед удалением. Если выбран этот параметр, вы увидите удаленные объекты, находящиеся в карантине, в главном окне . Каждая spyware-программа учитывается в карантине только один раз, вне зависимости от количества обнаруженных сигнатур. Для каждой программы выводятся дата и время, когда она была помещена в карантин. Если этот параметр не указан, после удаления все объекты будут полностью стерты из системы.

Каждый объект может быть восстановлен из карантина для выполнения своих обычных функций на вашем компьютере. Чтобы восстановить объект, щелкните соответствующую ссылку рядом с ним. Ключи реестра и файлы INI будут восстановлены на момент помещения их в карантин.

Вы можете восстановить программу и добавить ее в список исключений, выбрав соответствующую команду в контекстном меню объекта, чтобы не рассматривал ее как spyware. Вы также можете удалить объект навсегда, щелкнув ссылку Удалить рядом ним. Для того, чтобы полностью очистить карантин, воспользуйтесь соответствующей командой в контекстном меню модуля.

Внимание:

  • Не любое шпионское ПО может быть помещено в карантин.


Блокировка передачи персональных данных

позволяет вам задать персональные данные, чтобы защитить их от передачи вашим компьютером через Интернет-браузер, средства instant messaging, почтовые клиенты или другие приложения. Это обеспечивает защиту от кражи личных конфиденциальных данных таких как номер кредитной карты, пароли или другой важной и уникальной личной информации.

Для того, чтобы защитить ваши личные данные, выберите вкладку Личные данные в окне свойств подключаемого модуля Anti-Spyware и поставьте флажок Блокировка передачи персональных данных. Щелкните Добавить и в поле Данные для защиты введите любую комбинацию символов, букв и цифр, которую вы хотите защитить от утечки с вашего компьютера. Затем укажите описание строки и категорию, к которой она будет относиться. Щелкните OK, затем Применить - информация, содержащаяся в этой строке, будет заблокирована от передачи посредством исходящей связи.

Поставив флажок напротив Оповещать, можно установить, чтобы система оповещала вас каждый раз, когда компьютер пытается передать в сеть информацию, содержащуюся в Личных данных. Если вы отметите флажком Заменять персональные данные звездочками, запрашивающая сторона получит набор символов "*" вместо оригинальных данных.


Фильтрация почтовых вложений

Одним из самых простых путей для червей, Троянов и прочих вредоносных программы попасть на ваш компьютер является электронная почта. Сотни самовоспроизводящихся программ используют для рассылок базы электронных адресов ничего не подозревающих пользователей. Стоит пользователю только запустить вложенный файл, как сетевой червь или вирус начинает выполнять вредоносные действия, инфицируя систему и заставляя ее нестабильно работать.

Подключаемый модуль Фильтрация почтовых вложений защищает вас от вложений, содержащих вирусы и сетевые черви, проверяя вложения входящих почтовых сообщений и отфильтровывая потенциально опасные. С помощью этого модуля вы можете автоматически переименовывать почтовые вложения, чтобы они не могли повредить вашему компьютеру, а также получать соответствующие оповещения. Каждый тип вложений может управляться индивидуально в зависимости от расширения файла.

Задание типов почтовых вложений

уже содержит все наиболее часто встречающиеся типы файлов. Если в списке нету типа файла, для которого вы хотите установить правило, вы можете создать новое правило для данного типа файла, щелкнув правой кнопкой мыши на модуле в левой панели, выбрав Параметры и щелкнув кнопку Создать.

Введите расширение почтового вложения в поле Тип файла и его описание в соответствующем поле и щелкните OK. Выделите созданное правило и выберите действие, которое оно должно осуществлять для данного типа почтовых вложений. Возможны следующие варианты:

  • Переименовать файл. Вложение будет переименовано с тем, чтобы не оно не могло повредить вашему компьютеру. При попытке открыть файл, система спросит, доверяете ли вы источнику, из которго получен файл.
  • Сообщить. При получении вложения высветится предупреждение.

Вы можете изменять список типов почтовых вложений, удаляя некоторые расширения и возвращая списку его первоначальные настройки с помощью соответствующих кнопок.

Внимание:

  • Чтобы просмотреть почтовые вложения, заблокированные модулем Фильтрация почтовых вложений, выделите модуль в левой панели и щелкните кнопку Показать Журнал на информационной панели. Журнал событий отобразит события для модуля Фильтрация почтовых вложений. Более подробно о Журнале см. в разделе Слежение за сетевой активностью.


Предотвращение сетевых атак

Одним из важнейших аспектов защиты с помощью брандмауэра является фильтрация входящих пакетов, используемая для контроля входящей активности и блокировки хакеров и вредоносных программ при их попытке атаковать ваш компьютер.

Подключаемый модуль Детектор атак обнаруживает, предотвращает и оповещает вас обо всех возможных атаках на вашу систему из Интернета и локальной сети, к которой подключен ваш компьютер. Модуль просматривает входящие данные и определяет их законность либо с помощью сравнения контрольных сумм с известными атаками, либо производя анализ поведения. Это позволяет обнаруживать не только известные типы атак, такие как сканирование портов, Отказ от обслуживания (Denial of Service, DoS-атаки), атаки классов 'short fragments' и 'my address' и многие другие, но также и будущие угрозы.

Установка уровня тревоги

Вы можете определить насколько дотошно должен себя вести при обнаружении атак, установив требуемый уровень тревоги. Уровень тревоги определяет количество подозрительных пакетов, обнаруженных до того, как сообщает об атаке. Для того, чтобы установить уровень тревоги, щелкните правой кнопкой мыши на модуле в левой панели и выберите Свойства. Передвиньте ползунок в одно из следующих значений:

  • Максимальный. Оповещение об атаке отображается даже если обнаружено единичное сканирование одного из ваших портов.
  • Обычный. Оповещение об атаке отображается если просканировано несколько портов или если просканирован один из портов, которые, по мнению , обычно используются для атаки.
  • Безразличный. Оповещение об атаке отображается при обнаружении нескольких попыток атаки.

Измените уровень тревоги в соответствии с риском, которому подвергается ваш компьютер.

Вы также можете установить чувствительность к атакам, указав для каждого из уровней тревоги число подозрительных пакетов, необходимых для определения атаки. Для этого щелкните ссылку под ползунком и укажите числа.

Для получения визуальных и звуковых оповещений об обнаруженных атаках, установите флажки Опоещать при обнаружении атаки и Звуковое оповещение соответственно.

Блокировка атакующего

После обнаружения атаки может изменять свое поведение, чтобы автоматически защитить вас от возможных будущих атак с этого адреса. Для этого установите флажок Блокировать атакующего на и все данные с атакующего компьютера будут блокироваться в течение указанного промежутка времени. По умолчанию это 5 минут

Также, вы можете блокировать всю подсеть, к которой принадлежит адрес атакующего компьютера, выбрав параметр Блокировать подсеть атакующего.

Защита от Ethernet-атак

Благодаря контролю Ethernet- и Wi-Fi-соединений, модуль Детектор атак также обнаруживает и предотвращает некоторые Ethernet-атаки, такие как подделка IP-адреса (IP spoofing), сканирование ARP, ARP-флуд и другие, защищая вашу систему от вторжений из локальной сети. Чтобы указать настройки обнаружения Ethernet-атак, выберите вкладку Ethernet свойств модуля. Доступны следующие параметры:

  • Включить ARP-фильтрацию. Если включена, ARP-ответы от других узлов принимаются только при условии, что был послан запрос. Для каждого запроса принимается только первый ARP-ответ.
  • Блокировать атакующего когда он подменяет свои IP-адреса. Предотвращает так называемую подделку IP-адресов (атаки IP spoofing) когда атакующий изменяет свои IP-адреса.
  • Блокировать атакующего при смене MAC-адреса шлюза. Обнаруживает смену MAC-адреса сетевого адаптера шлюза и рапортует об атаке.
  • Защищать мои IP-адреса от ложных сообщений 'IP-адрес уже занят'. Блокирует ARP-ответы с IP-адресом адаптера, но с отличным MAC-адресом.
  • Блокировать узел при сканировании компьютеров в сети. Блокирует сканирование локальной сети.

Обнаруживаемы атаки

Вы можете выбрать какие атаки должен обнаруживать и предотвращать. По умолчанию, брандмауэр отслеживает более пятнадцати различных типов атак и угроз, но вы можете указать не обнаруживать некоторые атаки, чтобы понизить потребление системных ресурсов или уменьшить количество слишком частых ложных срабатываний, возникающих, например, если какая-либо служба в вашей сети ведет себя подобно источнику атаки.

Для настройки списка обнаруживаемых атак, выберите вкладку Дополнительно свойств модуля и щелкните Редактировать в группе Список атак. Щелкните Дополнительно, чтобы установить некоторые дополнительные параметры, такие как продолжительность атаки, и щелкните OK в каждом из окон для сохранения настроек.

Уязвимые порты

С точки зрения безопасности, TCP и UDP порты Вашей системы поделены на несколько групп в соответствии с вероятностью их взлома. Порты, отведенные для таких уязвимых служб как DCOM или RPC, должны контролироваться более тщательно, так как с большей вероятностью могут являться целью атаки.

Однако, если вы используете какие-то нестандартные службы, которым отведены нестандартные порты, то эти порты также могут являться лакомым кусочком для атакующего. Модуль Детектор атак позволяет задать список портов, на которые он будет обращать больше внимания во время слежения за сетевым трафиком.

Для того, чтобы указать порт как уязвимый, выберите вкладку Дополнительно свойств модуля и щелкните Указать в группе Уязвимые порты. Уязвимые порты делятся на две группы: системные и троянские. Занесите порты, которые используются уязвимыми системными службами, в список системных портов, а порты, используемые известными "Троянскими конями", в список троянских портов. Выберите вкладку в соответствии с тем, список каких портов вы хотите изменить.

Чтобы добавить порт, щелкните Добавить и укажите следующие параметры: протокол, номер порта и его вес опасности. Вес опасности – это десятичное число, указывающее степень важности данного порта. Чем больше вес, тем более уязвим этот порт. Вы также можете указать комментарий по своему желанию, например, описывающий назначение порта.

Доверенные узлы и порты

В вашей сети не исключено наличие компьютеров, которым вы полностью доверяете и которые, вы уверены, не могут являться источником опасности. Также, вы можете быть уверены, что некоторые порты вашей системы не могут являться плацдармом для вторжения. Другими словами, вы полагаете бесполезным слежение за этими узлами и портами и хотите сберечь расходуемые системные ресурсы, перестав следить за ними. Модуль Детектор атак позволяет вести списки исключений, в которые вы можете добавить узлы и порты, слежение за которыми вы хотите отключить.

Для добавления узла или порта в список доверенных, щелкните соответствующую кнопку в группе Исключения на вкладке Дополнительно свойств модуля и укажите необходимый узел или порт.

Внимание:

  • Для того, чтобы просмотреть атаки, обнаруженные и заблокированные модулем Детектор атак, выберите модуль на левой панели и щелкните кнопку Показать Журнал на информационной панели. Журнал событий отобразит события для модуля Детектор атак. Более подробно о Журнале событий см. в разделе Слежение за сетевой активностью.


Блокировка содержимого

Многие веб-сайты содержат сомнительное содержимое, множество заманчивых баннеров и ссылок приводят вас на страницы, содержащие информацию, нежелательную для просмотра вашими детьми.

Подключаемый модуль Содержимое избавляет вас от нежелательного содержимого, блокируя отображение указанных веб-сайтов или страниц, содержащих сомнительные материалы. Модуль Содержимое блокирует веб-страницы и сайты на основе ключевых слов, содержащихся в них и их URL, отображая в браузере указанное предупреждение каждый раз когда он пытается получить доступ к запрещенной странице.

Блокировка по ключевым словам

Также вы можете задать список ключевых слов для блокировки веб-страниц. Если страница содержит хотя бы одно слово из списка, она не будет отображена в веб-браузере. Для включения блокировки веб-сайтов по ключевым словам, щелкните правой кнопкой мыши модуль в левой панели и выберите Свойства. На вкладке Ключевые слова поставьте флажок Блокировать страницы, содержащие указанные ключевые слова.

Вы можете также управлять списком ключевых слов для блокировки. Для того, чтобы добавить слово в список блокировки, введите его в предназначенное для этого текстовое поле и щелкните Добавить. Слово появится в списке и страницы, содержащие это слово, не будут отображаться в вашем веб-браузере. Вы также можете редактировать и удалять ключевые слова из списка.

Блокировка по URL

Модуль Содержимое также блокирует указанные веб-сайты по их адресу URL. Вы можете указать слова, содержащиеся в адресе сайта, который не следует отображать (например, explosive или porn). Если адрес страницы содержит одно из таких слов, она не будет отображена.

Для включения блокировки веб-сайтов по URL, щелкните правой кнопкой мыши модуль в левой панели и выберите Свойства. На вкладке Адрес URL установите флажок Блокировать веб-сайты, адреса которых содержат ключевые слова.

Для того, чтобы добавить конкретный адрес веб-сайта или его часть в список блокировки, введите его в предназначенное для этого текстовое поле и щелкните Добавить. Строка появится в списке и страницы, адрес которых содержит эту строку, не будут отображаться в вашем веб-браузере. Вы также можете редактировать и удалять строки из списка.

Внимание:

  • Необязательно добавлять символ "*" в адрес, который вы вводите, т.к. модуль Содержимое производит поиск введенной подстроки во всем адресе URL. Например, если вы добавите "explosive", будут заблокированы следующие сайты: www.how-to-make-explosive.com, www.explosive.com, www.explosivetutorial.net и все остальные сайты, содержащие подстроку "explosive" в своем адресе.

Сообщение о блокировке содержимого

Модуль Содержимое позволяет указывать ваше собственное сообщение, которое будет выводится в окне браузера каждый раз, когда производится попытка доступа к запрещенной странице. Для того, чтобы изменить текст сообщения, выберите вкладку Разное свойств модуля и щелкните Редактировать в группе Сообщение. Укажите свое сообщение и щелкните OK, чтобы сохранить его.

Доверенные сайты

Если вам необходимо просматривать некоторые сайты независимо от их содержимого, вы можете добавить их в список доверенных сайтов, чтобы модуль не производил их блокировку. Для того, чтобы добавить сайт в список, щелкните Редактировать в группе Доверенные сайты на вкладке Разное и введите название сайта. Щелкните Добавить, чтобы добавить сайт в список и OK, чтобы закрыть окно. Брандмауэр не будет блокировать доверенные сайты.

Экспорт и импорт настроек подключаемого модуля

Вы можете экспортировать настройки подключаемого модуля в файл и загрузить их обратно из предварительно созданного файла. Эта возможность может быть полезна, если вы хотите быстро переключаться между различными настройками модуля. Например, одна конфигурация может блокировать доступ к содержимому "сайтов для взрослых", другая - блокировать рекламные объявления, третья - еще какое-нибудь нежелательное содержимое. Также это поможет перенести настройки с одного компьютера на другой и упростить начальную настройку на новых компьютерах.

Для того, чтобы экспортировать или импортировать настройки подключаемого модуля, щелкните соответствующую кнопку на вкладке Экспорт/Импорт свойств модуля. Введите имя файла и щелкните OK.

Внимание:

  • Чтобы просмотреть страницы, заблокированные подключаемым модулем Содержимое, выберите модуль на левой панели и щелкните кнопку Показать Журнал на информационной панели. Журнал событий отобразит события для подключаемого модуля Содержимое. Более подробно о Журнале событий см. в разделе Слежение за сетевой активностью.


Управление кэшем DNS

В сети Интернет каждый компьютер имеет свой собственный номер. Это так называемый IP-адрес. Пример IP-адреса - 64.176.127.178. Вам просто достаточно набрать этот числовой ряд в строке ввода браузера, нажать клавишу Enter, и браузер перейдет к веб-страницам данного компьютера.

Компьютер может без труда запоминать числовые IP-адреса, чего нельзя сказать о человеке. Поэтому была придумана адресная система, использующая слова и буквы, которая получила название Служба доменных имен (Domain Name System, DNS). Для большинства пользователей имя DNS является более близким понятием, чем IP-адрес. Пример имени DNS - http://www.agnitum.ru.

Имена DNS намного легче запомнить, однако браузерам необходимо знать IP-адрес, чтобы передавать данные по cети. Поэтому в Интернет существуют базы данных, которые хранят информацию о том, какой IP-адрес соответствует определенному имени DNS. Иногда, чтобы найти соответствие IP-адреса и имени DNS, браузер обращается к нескольким базам данных, находящимся в разных местах сети Интернет, что часто требует времени.

Для ускорения процесса создает и использует персонифицированную базу данных адресов DNS, хранащуюся на вашем компьютере. Она называется кэшем DNS (кэширование - запоминание) и вы можете настраивать ее по своему желанию.

поддерживает кэширование DNS автоматически, согласно вашим настройкам, и запоминает адреса, которые вы недавно использовали. Время, необходимое для хранения DNS, зависит от значения, которое вы укажете в настройках модуля DNS. Оно также зависит от того, как много имен DNS должно хранится в памяти . Сохраняются только недавно использованные имена с учетом максимального количества записей, указанного вами.

Управление кэшем DNS

Для включения кэша DNS щелкните правой кнопкой мыши модуль в левой панели и поставьте флажок Включить кэширование DNS. Вы можете указать предел для размера базы данных кэша DNS в виде количества записей, которые модуль должен хранить, и времени их устаревания. Установите флажки Ограничить кэш DNS и Записи DNS устаревают через и укажите соответствующее число записей для хранения и число дней, по истечении которого адрес должен быть удален из базы. Число дней измеряется со дня последнего использования адреса.

Внимание:

  • Не рекомендуется устанавливать неограниченный размер кэша и период устаревания, снимая оба флажка.

Блокировка неверных DNS-запросов

Служба DNS vможет стать источником потенциальной угрозы безопасности вашей системы, так как неверные DNS-запросы могут привести к ее зависанию или выполнению злонамеренного кода. Модуль DNS защищает вашу систему от неверных DNS-запросов и предотвращает их нежелательные последствия. Для включения защиты, поставьте флажок Проверять и блокировать неверные DNS-запросы в окне свойств модуля. Вы также можете включить блокировку сверхдлинных DNS-запросов, с помощью которых можно послать ваши личные данные в сеть в виде имени домена четвертого уровня или выше. Для этого поставьте флажок Блокировать сверхдлинные DNS-запросы.

Если вы хотите получать оповещения о заблокированных запросах, установите флажок Оповещать о блокированных DNS-запросах и каждый раз, когда неверный запрос будет заблокирован, вы увидите всплывающее оповещение.

Просмотр кэша DNS

Для просмотра и редактирования базы данных кэша DNS щелкните Редактировать в группе Записи DNS на вкладке Разное свойств модуля. В открывшемся диалоге вы можете видеть все DNS-записи, хранящиеся в кэше. Вы можете удалять записи выборочно или очистить весь кэш целиком, используя соответствующие кнопки.

Создание списка исключений

Если вы не хотите сохранять DNS-записи для определенных сайтов, например, если IP-адрес сайта меняется слишком часто или скорость разрешения его адреса и так достаточна велика и вы хотите сэкономить место в кэше для медленных сайтов, вы можете добавить этот сайт в список исключений. Для этого щелкните Редактировать в группе Исключения на вкладке Разное свойств модуля и укажите имя сайта. Щелкните Добавить и затем OK, чтобы закрыть окно. Адрес этого сайта больше не будет сохраняться в кэше.

Внимание:

  • Чтобы просмотреть адреса, сохраняемые подключаемым модулем DNS, выберите модуль на левой панели и щелкните кнопку Показать Журнал на информационной панели. Журнал событий отобразит события для подключаемого модуля DNS. Более подробно о Журнале событий см. в разделе Слежение за сетевой активностью.


Слежение за сетевой активностью

Для вашего удобства все действия и события на вашем компьютере, связанные с сетевой активностью, фиксируются и могут быть просмотрены с помощью специального приложения под названием Журнал событий. Журнал событий отображает все приложения и соединения, которые были разрешены или заблокированы , отдельные виды активности для каждого подключаемого модуля , запуск каждой программы и все изменения, вносимые в политики, настройки конфигурации и пароли.

Журнал событий позволяет гибко настраивать выводимые регистрируемые данные, выбирая для просмотра только ту информацию, которая вам нужна, сортировать ее нужным образом и фильтровать данные по любому параметру - порт, узел, приложение и другие.

Чтобы запустить Журнал событий, выберите Просмотр Журнала в меню Сервис в главном окне .

Внимание:

  • Также события можно просматривать с помощью Консоли управления Microsoft (Microsoft Management Console, MMC).
    • Для этого откройте консоль MMC, в меню Файл выберите Добавить/Удалить оснастку, щелкните Добавить и выберите из списка Журнал . Щелкните Добавить, Закрыть и OK, чтобы добавить оснастку в консоль.


Интерфейс Журнала событий

При запуске Журнала событий отображается его главное окно. В главном окне вы можете выбирать нужный журнал, просматривать информацию и изменять настройки Журнала событий. Элементы главного окна Журнала событий аналогичны элементам главного окна и управляются таким же образом.

Показать главное окно

Чтобы отобразить Журнал событий, когда свернут в значок в системном лотке:

  1. Щелкните правой кнопкой мыши на значке брандмауэра в системном лотке.
  2. Выберите Открыть Журнал событий.

Главное окно Журнала содержит:

Главное меню

Главное меню содержит различные команды для работы с Журналом событий.

Панель инструментов

Подробно см. в разделе Панель инструментов.

Строка представлений

Отображает название узла дерева, выбранного в левой панели.

Левая панель

См. раздел Левая и информационная панели.

Информационная панель

См. раздел Левая и информационная панели.

Строка состояния

Строка состояния находится в самой нижней части главного окна Журнала событий. Она отображает текущее состояние , число выбранных записей и общее число записей, отображаемых в информационной панели.

Показать строку состояния


Панель инструментов

Панель инструментов расположена в верхней части главного окна. Наведя на несколько секунд курсор мыши на каждую кнопку, вы прочитаете, что она делает.

Показать панель инструментов

Показать все кнопки на панели инструментов

Кнопка | Функция
 | Возвращает к предыдущему выбранному журналу.
 | Переходит к следующему выбранному журналу.
 | Переходит на уровень выше.
 | Показывает или скрывает левую панель.
 | Экспортирует выбранный журнал в текстовый файл.
 | Автоматически обновляет журнал.
 | Включает контекстную помощь Журнала событий.

Внимание:

  • Некоторые кнопки могут быть неактивны в зависимости от того, что выделено на левой и информационной панелях.


Левая и информационная панели

Для отображения собранной информации в дружественной пользователю манере, у Журнала событий имеется 2 панели. Левая панель напоминает левую панель Проводника Windows. Она отображает список журналов и фильтров. Информационная панель отображает специфические данные для каждого журнала, выделенного на левой панели.

Показать панели

Также как и в Проводнике Windows, любой узел, начинающийся со знака плюс ( [image]) можно раскрыть и просмотреть список его подкатегорий. Знак минус ( [image]) в начале строки означает, что узел уже раскрыт. Нажав на знак минус, все подкатегории узла будут спрятаны, что сохранит экранное пространство.

По умолчанию, левая панель показывает список, а информационная панель отображает содержимое следующих журналов:

Визуальные оповещения

Отображает все визуальные оповещения, которые были показаны пользователю.

История разрешенных

Отображает все соединения, которые были разрешены .

История заблокированных

Отображает все соединения, которые были заблокированы .

Контроль компонентов

Отображает все события Контроля компонентов .

Модули

Каждый подключаемый модуль имеет собственный журнал:

Интерактивные элементы

Отображает интерактивные элементы веб-страниц, которые были заблокированы на основе параметров для сценариев Java, VB, ActiveX и других интерактивных элементов. Более подорбно о подключаемом модуле Интерактивные элементы см. раздел Блокировка интерактивных элементов.

Реклама

Отображает все рекламные объявления, которые были заблокированы. Более подробно о подключаемом модуле Реклама см. в разделе Блокировка рекламы.

Anti-Spyware

Отображает все шпионские программы, которые были обнаружены и удалены/помещены в карантин на вашем компьютере. Более подробно о подключаемом модуле Anti-Spyware см. в разделе Защита от spyware.

Фильтрация почтовых вложений

Отображает все почтовые вложения, которые были нейтрализованы и помещены в карантин на вашем компьютере. Более подробно о подключаемом модуле Фильтрация почтовых вложений см. в разделе Фильтрация почтовых вложений.

Детектор атак

Отображает всю подозрительную сетевую активность и атаки на ваш компьютер из сети Интернет, задействованные порты и источники атак. Более подробно о подключаемом модуле Детектор атак см. в разделе Предотвращение сетевых атак.

Содержимое

Отображает веб-сайты и страницы, которые были заблокированы этим модулем и причины блокировки. Более подробно о подключаемом модуле Содержимое см. раздел Блокировка содержимого.

DNS

Отображает веб-адреса, сохраненные в памяти , для ускорения загрузки этих сайтов. Более подробно о подключаемом модуле DNS см. раздел Управление кешэм DNS.

Журнал системы

Здесь отображается история всех когда-либо запущенных программ и всех изменений, внесенных в политики брандмауэра, параметры программы и настройки конфигурации.

Для каждой группы записей (за исключением Визуальных оповещений, Контроля компонентов и Журнала системы) по умолчанию создается ряд полезных фильтров.

Внимание:

  • Вы можете создать для себя собственные фильтры, и добавить их в группы на левой панели.


Creating Multiple Configurations

Текущее состояние, в котором находится в каждый момент времени, характеризуется указанными настройками: правилами для приложений, глобальными правилами, настройками локальной сети, списками исключений для подключаемых модулей и так далее. Совокупность этих настроек называется конфигурацией. Первоначальная конфигурация создается во время установки брандмауэра и после этого вы можете изменять настройки и даже создавать различные конфигурации для различных целей. Это позволяет создавать отдельные конфигурации для каждого пользователя компьютера, предотвращая посещение детьми сайтов с нежелательным содержимым, закрывая им доступ к онлайн-играм или чатам в случае, если они используют компьютер родителей. Также это дает возможность передавать конфигурации с одного компьютера на другой и просто создавать резервные копии ваших настроек. Переключение между конфигурациями осуществляется очень просто.

Для создания новой конфигурации выберите пункт Новая конфигурация меню Файл. Мастер настройки поможет вам создать новую конфигурацию.

Мастер настройки предоставляет два способа настройки брандмауэра:

Автоматическая настройка

Если вы выберете Автоматическую настройку и щелкните Далее, автоматически просканирует вашу систему и установит все настройки без вашего участия. Брандмауэр обнаружит все известные сетевые приложения, установленные на вашем компьютере и определит какой уровень доступа в сеть должен быть установлен для каждого из них, настроит сетевые параметры и соберет базу данных Контроля компонентов. Правила создаются на основе встроенных предустановок и обеспечивают оптимальную производительность системы и безопасность приложений.

Автоматическая настройка намного быстрее использования Мастера настройки, но настройка каждого приложения при этом происходит на основе его установок по умолчанию, которые иногда могут оказаться не самыми оптимальными.

Ручная настройка

Если вы выбрали Ручную настройку, Мастер настройки проведет вас через процесс конфигурации, позволяя настроить брандмауэр в соответствии с вашими специфическими требованиями: указать необходимые настройки для каждой из сетей, к которым подсоединен ваш компьютер, а также для каждого из установленных сетевых приложений. Изменяя эти настройки, вы устанавливаете точный уровень безопасности, который будет обеспечивать для вашей системы. Мастер дает вам возможность настроить брандмауэр наиболее оптимальным образом, однако, это требует значительного времени и предполагает наличие знаний о конфигурации вашей системы.

После того, как вы щелкните Далее, автоматически определит ваше сетевое окружение. На шаге Настройка локальной сети вы увидите список сетей, к которым подсоединен ваш компьютер. Для просмотра и редактирования настроек сети щелкните Изменить. Вы сможете изменить эти настройки позднее во время работы с . Подробнее см. Настройки локальной сети.

Щелкните Далее, начнется поиск приложений, установленных на вашем компьютере, которые могут потребовать сетевой доступ, а по его завершении создадутся наборы правил для каждого из них. На шаге Поиск приложений вы можете просмотреть список таких приложений и отредактировать предложенные правила безопасности с помощью кнопки Подробнее. Вы можете отменить создание правил для некоторых приложений, сняв флажок рядом с его именем. Щелкните OK для сохранения и Далее для продолжения. Вы сможете изменить эти настройки позже во время работы с . Подробнее см. Настройка сетевого доступа для приложений.

Следующий шаг позволяет вам установить повышенный уровень безопасности, включив дополнительную защиту против методов обхода брандмауэров, используемых вредоносными программами. Эта защита включает в себя технологии Контроля скрытых процессов, Контроля памяти процессов и Контроля компонентов (подробнее см. Защита от действий вредоносных процессов). Если вам достаточно обычного уровня безопасности, а он подходит для большинства случаев, выберите соответствующий параметр для уменьшения количества запросов программы, требующих вашего участия.

Щелкните Далее. Если выбран параметр Повышенная безопасность (для продвинутых пользователей), будет собрана база Контроля компонентов и мастер автоматически перейдет на последний шаг.

Примечание:

  • В случае выбора обычного уровня безопасности, возможен отрицательный результат при прохождении некоторых тестовых программ (ликтестов).

На последнем шаге вы можете настроить остальные параметры , такие как политика брандмауэра, глобальные правила и другие, щелкнув Дополнительно. Откроется окно Параметры, позволяющее изменить любые настройки . По умолчанию создаваемая конфигурация получает имя configurationN.cfg, где N - увеличивающийся индекс, и сохраняется в папке установки . Если вы хотите сохранить конфигурацию в другом месте, щелкните Изменить и укажите папку для сохранения. Щелкните Готово, чтобы применить и сохранить созданную конфигурацию.

Вы можете создать несколько конфигураций на основе текущих настроек, просто присвоив каждой из них отличное имя с помощью команды Сохранить конфигурацию как меню Файл. Для переключения конфигурации выберите Загрузить конфигурацию в меню Файл и укажите файл конфигурации или просто щелкните по имени конфигурации в меню Файл.

Конфигурация может быть защищена от изменения или смены на другую с помощью пароля. Подробнее см. Защита настроек брандмауэра.

Примечание:

  • При выходе из , файл текущей конфигурации сохраняется, и автоматически загружается при следующем запуске .


Agnitum ImproveNet

ImproveNet

Мы приглашаем вас внести свой вклад в безопасность Интернета, участвуя в бесплатной объединённой программе ImproveNet, направленной на улучшение качества, безопасности и функций контроля продуктов . С вашей стороны не требуется никаких действий. Вы просто даете свое согласие на сбор некоторых неперсональных данных, который будет производиться раз в неделю для расширения базы данных приложений и создания большего числа автоматических правил доступа, доступных пользователям. Это уменьшит количество всплывающих окон, требующих вашего внимания.

С вашего согласия, будет собирать информацию только о сетевых приложениях, установленных на вашем компьютере. Данные собираются полностью анонимно, без имен, адресов или какой бы то ни было другой персональной информации. просто собирает данные о сетевых приложениях, для которых не существует правил, новые системные правила, а также общую статистику использования приложений. Информация отсылается в раз в неделю в сжатом виде в фоновом режиме, не прерывая вашу работу в системе.

После того, как полученное новое правило доступа утверждается в компании , оно автоматически становится доступным всем пользователям через Обновление наряду с другими обновлениями.

Пожалуйста, присоединяйтесь к программе ImproveNet, чтобы помочь нам в обеспечении большей безопасности пользователей сети Интернет. Выберите команду Помощь > ImproveNet и отметьте флажок Я хочу анонимно участвовать в программе ImproveNet и помогать компании в сборе данных о сетевых приложениях, установленных на моем компьютере. Вы можете выключить эту возможность в любое время просто сняв этот флажок.


Служба технической поддержки

Если вам необходима помощь при работе с , пожалуйста посетите страницу службы технической поддержки по адресу http://www.agnitum.ru/support/index.php. Среди предлагаемых служб - база знаний, документация, онлайн форум службы поддержки, полезные веб-ресурсы, а также непосредственная связь с инженерами службы технической поддержки.

Если вы используете бесплатную версию Outpost Firewall FREE, мы не сможем оказать вам персональную техническую поддержку.


.//============== opst_ui ==============
.topic 0x00010153
Нажмите для обновления продукта.

.topic 0x00010152
Нажмите, если Вы не хотите производить обновление.

.topic 0x00000001
Закрывает диалоговое окно и сохраняет внесенные изменения.

.topic 0x00000002
Закрывает диалоговое окно без сохранения внесенных изменений.

.topic 0x808b0004
Применяет и сохраняет внесенные изменения, не закрывая диалоговое окно.

.topic 0x000100dc
Позволяет добавить приложение в список.

.topic 0x000100db
Перечень действий, возможных для приложения.

.topic 0x000100f9
Перечень событий, возможных для приложения

.topic 0x00010118
Имя правила.

.topic 0x00010137
Описание правила.

.topic 0x0001011d
Поле ввода пароля.

.topic 0x0001011e
Поля ввода нового пароля.

.topic 0x0001014f
Поля ввода старого пароля.

.topic 0x000100f6
Активирует защиту паролем.

.topic 0x000100f3
Деактивирует защиту паролем.

.topic 0x0001013e
Позволяет задать пароль.

.topic 0x00010113
Флажок означает, что кнопка закрытия будет сворачивать окно Outpost, а не закрывать приложение его.

.topic 0x00010114
Флажок означает, что Outpost запускается в свернутом виде, без кнопки на панели инструментов, но со значком на панели задач.

.topic 0x00010140
Загружает Outpost Firewall автоматически при загрузке  системы и отображает значок брандмауэра на панели задач.

.topic 0x00010141
Загружает Outpost Firewall в скрытом режиме, без отображения значка на панели задач и диалоговых окон.

.topic 0x0001013f
Outpost Firewall не загружается автоматически прири запуске системы.

.topic 0x000100de
Позволяет добавить приложение к перечню приложений  Outpost.

.topic 0x000100f5
Позволяет изменять прараметры для выделенного приложения.

.topic 0x00010133
Удаляет выделенное приложение из перечня.

.topic 0x0001014d
Перечень приложений Outpost.

.topic 0x000100ed
Показывает перечень компонентов каждого приложения.

.topic 0x00010101
Позволяет настраивать параметры ICMP.

.topic 0x0001012a
Позволяет задавать общие правила для приложений и системы.

.topic 0x0001012e
Включает обычный режим, когда IP-адрес компьютера виден в сети.

.topic 0x0001012f
Включает скрытый режим, когда IP-адрес компьютера не виден в сети.

.topic 0x0001010e
Перечень установленных фильтров, которые может использовать Outpost.

.topic 0x00010125
Добавляет в перечень новый модуль.

.topic 0x00010126
Удаляет выделенный модуль из перечня.

.topic 0x00010127
Позволяет изменять параметры выделенного модуля.

.topic 0x00010128
Запускает выделенный модуль.

.topic 0x00010129
Останавливает выделенный модуль.

.topic 0x00010138
Позволяет изменять выделенное правило.

.topic 0x00010139
Перемещает выделенное правило вниз по перечню правил для приложения. Перемещением вниз уменьшает его приоритет по отношению к правилам в перечне.

.topic 0x0001013a
Перемещает выделенное правило вверх по перечню правил для приложения. Перемещением вверх повышает его приоритет по отношению к правилам в перечне.

.topic 0x0001013b
Добавляет новое правило для приложения.

.topic 0x0001013c
Создает правила для приложения на основе успешных правил для похожего приложения.

.topic 0x0001013d
Удаляет выделенное правило.

.topic 0
Перечень правил для приложения. Поставьте флажок, чтобы активировать правило.

.topic 0x000100db
Перечень возможных действий, возможных для приложения.

.topic 0x000100f9
Перечень действий, возможных для приложения.

.topic 0x00010118
Имя правила.

.topic 0x000100d9
Указывает, что процесс должен быть разрешен однократно.

.topic 0x000100da
Указывает, что процесс должен быть блокирован однократно.

.topic 0x000100e4
Указывает, что все процессы для данного приложения должны быть разрешены.

.topic 0x000100e5
Указывает, что все процессы для данного приложения должны быть блокированы.

.topic 0x000100e6
Указывает, что правило для приложения должно быть создано на основе прежнего (стандартного) правила для похожего приложения.. Чтобы создать собственное правило, выберите «другое» в выпадающем меню и нажмите OK.

.topic 0x00010112
Список доступных наборов правил по умолчанию.

.topic 0x000100e0
Флажок означает, что разрешенная папка должна отображаться.

.topic 0x000100e9
Флажок означает, что блокированная папка должна отображаться.

.topic 0x000100f8
Флажок означает, что папка сетевой активности должна отображаться.

.topic 0x0001010f
Флажок означает, что строка папок должна отображаться.

.topic 0x00010110
Флажок означает, что строка состояния должна отображаться.

.topic 0x00010111
Флажок означает, что панель инструментов должна отображаться.

.topic 0x0001011f
Флажок означает, что папка открытых портов должна отображаться.

.topic 0x00010134
Флажок означает, что папка отчета  должна отображаться.

.topic 0x0001010c
Перечень активных сеансов правила.

.topic 0x00010144
Добавляет время к активному сеансу правила.

.topic 0x00010145
Назначает правило, которое должно быть активным каждый день.

.topic 0x00010146
Поле для выбора времени активности правила.

.topic 0x00010147
Нужно для обозначения начала временного интервала.

.topic 0x00010148
Назначает правилу быть активным в определенные промежутки времени.

.topic 0x00010149
Позволяет изменять правило в перечне временных интервалов, когда правило активно.

.topic 0x0001014a
Дективирует правило.

.topic 0x0001014b
Удаляет время активности правила.

.topic 0x0001014c
Нужно для обозначения конца временного интервала.

.topic 0x000100fa
Выпадающий список объектов, показанных в истории.

.topic 0x000100fb
Поле ввода даты, с которой должна начаться фильтрация

.topic 0x000100fc
Если выбрано (точкой) указывает, что фильтрация должна начаться с определенного времени/даты.

.topic 0x000100fd
Если выбрано (точкой) указывает, что журналы должны быть показаны с начала.

.topic 0x000100fe
Поле ввода времени начала фильтрации.

.topic 0x00010107
Поле ввода даты, до которой должна продолжаться фильтрация.

.topic 0x00010108
Если выбрано (точкой) указывает, что фильтрация должна закончиться к определенной дате/времени.

.topic 0x00010109
Если выбрано (точкой) указывает, что журналы должны быть показаны до последней записи.

.topic 0x0001010a
Поле ввода даты, до которой фильтрация должна продолжаться.

.topic 0x0001014e
Поле ввода состояния, которое должно быть показано в истории.

.topic 0x00010136
Копирует выделенное правило.

.topic 0x00010115
Позволяет изменять выделенное поле в перечне.

.topic 0x00010116
Перемещает выделенное поле вниз по перечню. Перемещение вниз уменьшает приоритет правила. Перечень показывает расположение правил.

.topic 0x00010117
Перемещает выделенное поле вверх по перечню. Перемещение вверх повышает приоритет правила. Перечень показывает расположение правил.

.topic 0x0001011c
Добавляет новое правило в перечень.

.topic 0x00010131
Удаляет выделенное правило из перечня.

.topic 0x00010135
Перечень общих правил для приложений и системы. Поставьте флажок, чтобы активировать правило.

.topic 0x0001012b
Выберите, чтобы разрешить все операции посредством этого протокола.

.topic 0x0001012c
Выберите, чтобы запретить все операции посредством этого протокола.

.topic 0x0001012d
Выберите, чтобы создать выборочные правила для этого протокола.

.topic 0x0001011b
Настройки локальной сети.

.topic 0x000100e8
Автоматически находит новое сетевое окружение, так что не нужно добавлять его вручную.

.topic 0x00010104
Добавляет новую настройку локальной сети в перечень.

.topic 0x00010105
Обнаруживает сеть автоматически.

.topic 0x00010106
Удаляет выделенную строку из перечня.

.topic 0x00010119
Приложение, которое запустится, когда начнет действовать правило.

.topic 0x00010154
Позволяет искать в компьютере приложение, которое нужно запустить.

.topic 0x0001010d
Перечень политик брандмауэра

.topic 0x00008047
Изменяет политику Outpost Firewall.

.topic 0x00008009
Открывает диалоговое окно Параметры.

.topic 0x0000805D
Проверяет обновления для модулей и компонентов Outpost Firewall.

.topic 0x00009C5F
Открывает Журнал событий, отображающий фильтры.

.topic 0x0000E145
Показывает темы справки Outpost Firewall.

.topic 0x000100dd
Нажмите для добавления приложения в список имеющих доступ к rawsockets.

.topic 0x000100df
Позволяет указать дополнительные настройки конфигурации.

.topic 0x000100e1
Разрешает доступ в сеть для приложения.

.topic 0x000100e2
Разрешает доступ к rawsocket для данного приложения.

.topic 0x000100e3
Правило будет применено в случае если событие удовлетворяет всем указанным критериям.

.topic 0x000100e7
Выберите для автоматической настройки Outpost.

.topic 0x000100ea
Блокирует доступ в сеть для приложения.

.topic 0x000100eb
Блокирует доступ к rawsocket для данного приложения.

.topic 0x000100ec
Нажмите для изменения пути установки программы.

.topic 0x000100ee
Выключает Контроль компонентов.

.topic 0x000100ef
Устанавливает Максимальный уровень Контроля компонентов.

.topic 0x000100f0
Устанавливает Обычный уровень Контроля компонентов.

.topic 0x000100f1
Сбрасывает системные настройки к значениям по умолчанию.

.topic 0x000100f7
Включает Контроль компонентов.

.topic 0x00010100
Выключает автоматические обновления. Вы можете включить их позднее выбрав Сервис > Автоматически проверять обновления в главном окне Outpost.

.topic 0x00010103
Загрузить настройки из файла.

.topic 0x0001010b
Список сетей, к которым подключен Ваш компьютер.

.topic 0x103
Нажмите для изменения настроек сетей, к которым подключен Ваш компьютер.

.topic 0x00010121
Правило будет применено в случае если событие удовлетворяет любому из указанных критериев.

.topic 0x00010123
Укажите параметры, которые будут переданы приложению.

.topic 0x00010124
Укажите пароль.

.topic 0x841b03ed
Список приложений, которым разрешен доступ к rawsockets.

.topic 0x00010130
Нажмите для редактирования списка приложений, которым разрешен доступ к rawsockets.

.topic 0x00010132
Удаляет приложение из списка приложений, которым разрешен доступ к rawsockets.

.topic 0x00010151
Выберите для ручной настройки Outpost.

.topic 0x000100ff
Нажмите для настройки контроля скрытых процессов.

.topic 0x00010120
Нажмите для настройки контроля памяти процессов.

.topic 0x00008047
Позволяет изменить политику Outpost Firewall.

.topic 0x00008009
Открывает диалоговое окно Параметры.

.topic 0x0000801E
Позволяет изменить порядок в списке объектов.

.topic 0x00008020
Позволяет отображать события за определенный период времени.

.topic 0x0000E801
Показывает описание выделенных объектов и информацию о текущей политике.

.topic 0
Выберите для включения автоприменения правил для уменьшения числа запросов программы.

.topic 0
Выберите, если вы не хотите чтобы правила создавались автоматически.

.topic 0
Щелкните для указания политики фонового режима и настройки счетчиков бездействия.

.topic 0
Снимите флажок, если не хотите засорять журналы информацией и широковещательных сообщениях NetBIOS.

.topic 0x00009C75
Запускает Spyware-сканер.

.//============== eo opst_ui ==============

.//============== engine ==============
.topic 0x00010037
Разрешает доступ в сеть для данного скрытого процесса.

.topic 0x0001003c
Блокирует доступ в сеть для данного скрытого процесса.

.topic 0x0001003e
Блокирует всю сетевую активность для данного приложения до его перезапуска.

.topic 0x0001003f
Помещает измененные компоненты данного приложения в список общих компонентов, чтобы другие приложения также могли их использовать.

.topic 0x00010040
Обновляет информацию о компонентах данного приложения.

.topic 0x00010041
Текстовое поле для ввода регистрационного кода.

.topic 0x00010042
Список подключаемых модулей Outpost.

.topic 0x00010044
Разворачивает cписок подключаемых модулей Outpost.

.topic 0x00010045
Вставляет регистрационный код в предоставленное поле.

.topic 0x00010049
Адрес, к которому приложение запрашивает доступ.

.topic 0x0001004a
Приложение на удаленном сервере, к которому данное приложение запрашивает доступ.

.topic 0x0001004b
Служба на удаленном сервере, к которой данное приложение запрашивает доступ.

.topic 0x0001004c
Нажмите для ввода нового регистрационного кода.

.topic 0x0001004d
Нажмите для обновления регистрационного кода.

.topic 0x00010051
Нажмите для ввода нового регистрационного кода.

.topic 0x00010052
Направляет Вас на web-страницу на сайте Agnitum, содержащую информацию о покупке Oupost со скидкой.
.//============== eo engine ==============

.//============== op_cmn ==============

.topic 0x00010061
Добавляет новый адрес в перечень удаленных адресов.

.topic 0x00010062
Перечень удаленных адресов, которые Вы хотите разрешить.

.topic 0x00010063
Позволяет корректировать выделенный адрес в перечне удаленных адресов.

.topic 0x00010064
Удаляет выделенный адрес из перечня удаленных адресов.

.topic 0x00010089
Позволяет указать имя домена.

.topic 0x0001008a
Позволяет указать IP-адрес.

.topic 0x0001008b
Позволяет указать диапазон IP-адресов.

.topic 0x00010060
Здесь вводится удаленный адрес: имя домена, IP-адрес или ряд IP-адресов.

.topic 0x00010068
Перечень портов с указанием их имен, номеров и описаний.

.topic 0x0001007d
Поле ввода, где нужно указать номер порта, имя порта и ряд портов.

.topic 0x0001006d
Перечень протоколов ICMP. Флажок в столбце В разрешает системе принимать тип сигнала ICMP. Флажок в столбце ИЗ разрешает системе посылать тип сигнала ICMP.

.topic 0x0001006f
Возврат к параметрам по умолчанию, определенным разработчиками.

.topic 0
Определяет трафик (данные), поступающий на Ваш компьютер или сеть.

.topic 0
Определяет трафик (данные), поступающий с Вашего компьютера или сети.

.topic 0x000100bf
Назначает использование протокола TCP.

.topic 0x000100c6
Назначает использование протокола UDP.

.topic 0
Назначает использование протокола IP.

.topic 0
Не назначает протокол.

.topic 0x00010065
Добавляет выделенное поле к списку полей.

.topic 0x00010066
Добавляет выделенное поле к заголовку столбца.

.topic 0x00010067
Позволяет настраивать расширенные функции.

.topic 0x00010076
Список доступных полей.

.topic 0x00010077
Список всех полей. Это поля, которые будут показаны, если Вы нажмете знак +, предшествующий каждой строке на Информационной панели.

.topic 0x00010079
Список заголовков столбцов. Эти поля всегда показываются.

.topic 0x0001007f
Удаляет, перемещает вверх или вниз выделенное поле.

.topic 0x00010080
Удаляет, перемещает вверх или вниз выделенное поле.

.topic 0x00010081
Удаляет выделенное поле из собственного списка и помещает его в список доступных полей.

.topic 0x00010082
Удаляет выделенный заголовок столбца из собственного столбца и помещает его в список доступных полей.

.topic 0x00010069
Назначает Outpost всегда разрешать IP-адрес в имени DNS.

.topic 0x0001006a
Назначает Outpost показывать трафик в наиболее удобном формате.

.topic 0x0001006b
Назначает Outpost показывать трафик в байтах.

.topic 0x0001006c
Назначает Outpost разрешать IP-адрес в имени DNS, если только имя DNS содержится в кэш-памяти.

.topic 0x00010075
Назначает Outpost показывать трафик в килобайтах.

.topic 0x0001007a
Назначает Outpost показывать трафик в мегабайтах.

.topic 0x0001007b
Назначает Outpost никогда не разрешать IP-адрес в имени DNS.

.topic 0x0001007c
Назначает Outpost показывать номер порта, но не его имя.

.topic 0x0001007e
Назначает Outpost показывать имя порта, но не его номер.

.topic 0x00010078
Перечень доступных протоколов.

.topic 0x0001006e
Список столбцов. Флажок напротив столбца означает, что его нужно показывать в главном окне Outpost.

.topic 0x00010072
Перемещает столбец вниз списка. Это означает, что столбец будет сдвинут вправо от  других столбцов.

.topic 0x00010088
Перемещает столбец вверх списка. Это означает, что столбец будет сдвинут влево от  других столбцов.

.topic 0x00010083
Возвращает параметры списка, заданные разработчиками по умолчанию.

.//============== eo op_cmn ==============

.//============== op_data ==============
.topic 0x0001008c
Включает уборщик журнала.

.topic 0x0001008d
выключает уборщик журнала.

.topic 0x0001008f
Максимальное количество записей в базе для каждого журнала.

.topic 0x00010090
Отметьте для задания ограничения размера журнала по количеству записей.

.topic 0x00010091
Отметьте для создания новой базы журнала при следующем запуске системы.

.topic 0x00010092
Нажмите для задания индивидуальных настроек журналов Оutpost.

.topic 0x00010093
Максимальное количество дней, в течение которых записи будут храниться в журнале.

.topic 0x00010094
Отметьте для задания ограничения размера журнала по количеству дней.

.topic 0x00010097
Использовать индивидуальные настроки ограничения размера для каждого журнала Outpost.

.topic 0x00010098
Список журналов Outpost. Отметьте журнал для включения его очистки и задайте количество записей и срок, в течение которого они будут храниться.

.topic 0x00008009
Нажмите для изменения установок уборщика журнала.

.topic 0x0001009d
Использовать общие настройки для всех журналов.

.topic 0x0001009f
Максимальный размер базы журнала Outpost в мегабайтах.

.topic 0x000100a0
Отметьте для задания ограничения максимального размера базы журнала Outpost.

.topic 0x00010095
Выберите, если Вы не хотите в дальнейшем получать это сообщение.

.topic 0x00010096

.topic 0x00010099
Загружает драйверы ODBC.

.topic 0x0001009a
Нажмите для отображения описания ошибки.

.topic 0x0001009e
Выберите, если хотите получать визуальные оповещения во время очистки Журнала.

.topic 0x000100a1

.topic 0x000100a2
Направляет Вас на web-страницу с часто задаваемыми вопросами на сайте Agnitum.
.//============== eo op_data ==============

.//============== op_log ==============
.topic 0x000100a6
Назначает дату, до которой все записи должны быть удалены.

.topic 0x000100a9
Определяет, что все записи фильтра должны быть удалены.

.topic 0x000100aa
Позволяет назначать дату, до которой записи должны быть удалены.

.IDD_DIRECTION (2) ********************************************************************************

.topic 0x000100b4
Флажок определяет направление трафика, поступающего на Ваш компьютер или сеть.

.topic 0x000100b8
Флажок определяет направление трафика, поступающего от Вашего компьютера или сети.

.IDD_FILTER (3) ***********************************************************************************

.topic 0x000100ae
Назначает правила фильтрации для отображаемых событий.

.topic 0x000100b1
Назначает имя для правила, которое Вы создаете.

.topic 0x000100be
Показывает описания правил фильтрации.

.IDD_FILTER_BYTES (3) *****************************************************************************

.topic 0x000100a4
Позволяет назначать состояние правила фильтрации.

.topic 0x000100ac
Позволяет указывать  значение для выбранного состояния.

.topic 0x000100ad
Позволяет указывать  значение для выбранного состояния.

.IDD_FILTER_CHECK (1) *****************************************************************************

.topic 0x000100b5
Показывает список опций для фильтра.

.IDD_FILTER_CHECK_EX (2) **************************************************************************

.topic 0
Показывает список опций для фильтра.

.topic 0x000100ab
Показывает выбранные значения.

.IDD_FILTER_TIME (7) ******************************************************************************

.topic 0x000100a3
Позволяет выбрать определенный временной интервал.

.topic 0x000100a5
Поле для выбора даты, с которой нужно начать фильтрацию.

.topic 0x000100a7
Поле для выбора даты, до которой нужно продолжать фильтрацию.

.topic 0x000100bb
Позволяет выбрать тип ограничений.

.topic 0x000100bc
Позволяет выбрать тип ограничений.

.topic 0x000100c0
Поле для ввода времени, с которого нужно начать фильтрацию.

.topic 0x000100c1
Поле для ввода времени, до которого нужно продолжать фильтрацию.

.IDD_LOG_OPTIONS (12) *****************************************************************************

.topic 0x000100a8
Возврат к параметрам по умолчанию, определенным разработчиками.

.topic 0x000100af
Назначает Журналу Outpost показывать имена приложений вместе со значками.

.topic 0x000100b0
Назначает Журналу Outpost показывать имена приложений вместе с маршрутами.

.topic 0x000100b2
Назначает Журналу Outpost показывать сетку таблицы.

.topic 0x000100b9
Назначает Журналу Outpost показывать номер порта.

.topic 0x000100ba
Назначает Журналу Outpost показывать имя порта, но не его номер.

.topic 0x000100c2
Назначает Журналу Outpost показывать трафик в наиболее удобном формате.

.topic 0x000100c3
Назначает Журналу Outpost показывать трафик в байтах.

.topic 0x000100c4
Назначает Журналу Outpost показывать трафик в килобайтах.

.topic 0x000100c5
Назначает Журналу Outpost показывать трафик в мегабайтах.

.topic 0x000100b6
Назначает Журналу Outpost показывать удаленный узел как разрешенное имя.

.topic 0x000100bd
Назначает Журналу Outpost показывать удаленный узел как IP-адрес.

.IDD_PROTOCOL (4) *********************************************************************************

.topic 0x000100b3
Назначает отображение протокола ICMP.

.topic 0x000100bf
Назначает отображение протокола TCP.

.topic 0x000100c6
Назначает отображение протокола UDP.

.topic 0x000100b7
Назначает отображение любых протоколов, исключая вышеперечисленные.

.GRIDS (4) ****************************************************************************************

.topic 0x00002725
Обновляет текущий фильтр.

.topic 0x00007918
Создает новый фильтр.

.topic 0x00007919
Редактирует существующий фильтр.

.topic 0x0000791A
Удаляет ненужный фильтр.

.topic 0x0001008c
Включает Уборщик Журнала.

.topic 0x0001008d
Выключает Уборщик Журнала.

.topic 0x0001008f
Укажите максимальное число записей, которые должны храниться в каждом журнале в базе данных.

.topic 0x00010090
Выберите этот параметр, чтобы ограничить размер журнала указанным количеством записей.

.topic 0x00010091
Выберите, чтобы при следующем запуске Outpost Firewall создал новую базу данных Журнала.

.topic 0x00010092
Нажмите для указания индивидуальных размеров для каждого журнала.

.topic 0x00010093
Укажите максимальное число дней для хранения записей в Журнале.

.topic 0x00010094
Выберите этот параметр для указания срока хранения записей в Журнале.

.topic 0x00010097
Выберите для указания индивидуальных настроек очистки для каждого журнала.

.topic 0x806903ee
Список журналов Outpost. Выберите журнал для включения его очистки. Укажите число записей и число дней для хранения записей журнала.

.topic 0x00008009
Нажмите для настройки параметров Уборщика Журнала.

.topic 0x0001009d
Выберите для применения текущих настроек ко всем журналам Outpost.

.topic 0x0001009f
Укажите максимальный размер базы данных Журнала Outpost в мегабайтах.

.topic 0x000100a0
Выберите для ограничения размера базы данных Журнала Outpost.

.topic 0x0001009c
Выберите, чтобы при следующем запуске Outpost Firewall восстановил базу данных Журнала.

.//============== eo op_log ==============

.//============== op_viewer ==============
.topic 0x000100d8
Флажок означает, что  Дерево консоли следует отображать.

.topic 0x000100d7
Флажок означает, что  Панель инструментов следует отображать.

.topic 0x000100cb
Флажок означает, что Строку описания следует отображать.

.topic 0x000100d6
Флажок означает, что Строку состояния следует отображать.

.IDD_FAVORITES_ADD_TO (3) *************************************************************************

.topic 0x000100d1
Показывает имя текущего фильтра, который Вы просматриваете в том виде, в котором оно появится в папке Избранное.

.topic 0x000100cd
Показывает список папок во вкладке Избранное.

.topic 0x000100d4
Создает новую папку в списке Избранное.

.TOOLBAR (6) **************************************************************************************

.topic 0x0000800A
Возвращается к предыдущему элементу выделения.

.topic 0x0000800B
Переходит к следующему элементу выделения.

.topic 0x0000800C
Переходит на один уровень вверх.

.topic 0x0000800D
Скрывает или показывает Дерево консоли.

.topic 0x0000801A
Экспортирует выделенный фильтр в текстовый файл.

.IDD_FAVORITES_MOVE (1) ***************************************************************************

.topic 0x000100ce
Выберите папку, в которую Вы хотите перемесить выделенный фильтр.

.IDD_FAVORITES_ORGANIZE (6) ***********************************************************************

.topic 0x000100c9
Создает новую папку в списке Избранное.

.topic 0x000100d3
Перемещает выбранный фильтр в другое место.

.topic 0x000100d5
Переименовывает выбранный фильтр.

.topic 0x000100ca
Удаляет выбранный фильтр.

.topic 0x000100cf
Отображает папки в списке Избранное.

.topic 0x000100cc
Показывает описание выбранного фильтра.

.topic 0x0000801B
Включает автоматическое обновление журнала.
.//============== eo op_viewer ==============

.//============== ads ==============
.topic 0x00010018
Блокирует целую строку HTML.

.topic 0x0001000d
Часть строки HTML, которая должна быть блокирована.

.topic 0x0001000e
Блокирует часть строки HTML.

.IDD_PAGE_HTMLSTR (8) *****************************************************************************

.topic 0x00010000
Добавляет в список строку HTML, указанную в поле.

.topic 0x00010001
Возвращает список строку HTML в состояние, принятое разработчиками по умолчанию.

.topic 0x00010003
Поле ввода строки HTML, которую нужно блокировать.

.topic 0x00010004
Флажок включает блокировку объявлений по строкам HTML.

.topic 0x0001000b
Список строк HTML.

.topic 0x0001000c
Позволяет изменять выделенную строку HTML в списке.

.topic 0x00010011
Удаляет выделенную строку HTML из списка.

.topic 0x00010012
Флажок в этой ячейке показывает корзину для рекламы на рабочем столе.

.IDD_PAGE_IMGSIZE (7) *****************************************************************************

.topic 0x00010006
Флажок разрешает блокировку рекламы по размеру изображения.

.topic 0x00010008
Поле ввода для указания высоты изображения.

.topic 0x00010009
Поле ввода для указания ширины изображения.

.topic 0x00010013
Добавляет размер (ширину и высоту), указанный в списке размеров изображений.

.topic 0x00010014
Список размеров изображений для блокировки.

.topic 0x00010015
Позволяет изменять выделенный размер изображений в списке.

.topic 0x00010016
Удаляет выделенный размер изображений из списка.

.topic 0x00010002
Сбрасывает список размеров изображений к списку по умолчанию.

.topic 0x00010005
Включает блокировку рекламных объектов (таких така Flash-анимации).

.topic 0x00010007
Нажмите для сохранения конфигурации модуля в файл.

.topic 0x0001000a
Нажмите для загрузки конфигурации модуля из файла.

.topic 0x00010017
Нажмите для добавления/удаления сайта в/из списка Доверенных сайтов.

.topic 0x0001000f
Заменяет рекламные изображения прозрачным изображением равного размера.

.topic 0x00010010
Заменяет рекламные изображения текстовым сообщением [AD].
.//============== eo ads ==============

.//============== content ==============
.topic 0x0001001b
Флажок включает блокировку по имени домена.

.topic 0x05
Поле для ввода имени домена  (напр,. asite.com). Примечание: не используйте символы замены.

.topic 0x04
Список адресов для блокировки.

.topic 0x01001
Добавляет указанный в поле ввода адрес к списку блокировки.

.topic 0x01002
Удаляет выделенный сайт из списка.

.topic 0x03
Позволяет изменять выделенный адрес в списке блокировки.

.IDD_PAGE_CONTENTWORD (6) *************************************************************************

.topic 0x0001001c
Флажок позволяет блокировать web-страницы по содержимому.

.topic 0x06
Добавляет указанное в поле ввода слово или фразу к списку блокировки.

.topic 0x07
Удаляет выделенное слово из списка блокировки.

.topic 0x08
Позволяет изменять выделенное слово в списке блокировки.

.topic 0x09
Перечень слов для блокировки странцы.

.topic 0x0a
Поле ввода слов для блокировки.

.topic 0x20
Нажмите для редактирования сообщения, которое появляется на странице с блокированным содержимым.

.topic 0x0001001d
Нажмите для сохранения конфигурации модуля в файл.

.topic 0x00010022
Нажмите, чтобы указать список доверенных серверов. Outpost не будет блокировать содержимое этих сайтов.

.topic 0x0001001e
Нажмите для загрузки конфигурации модуля из файла.

.topic 0x10
Добавляет указанный сервер в список.

.topic 0x11
Удаляет выделенный сервер из списка доверенных.

.topic 0x12
Нажмите для изменения адреса сервера.

.topic 0x13
Список доверенных сайтов.

.topic 0x14
Укажите адрес сервера для занесения в список доверенных.
.//============== eo content ==============

.//============== dns ==============
.topic 0x00010026
Поле ввода количества дней устаревания DNS.

.topic 0x00010028
Флажок включает время устаревания DNS.

.topic 0x00010029
Флажок включает ограничение кэш DNS.

.topic 0x0001002a
Кэш записей DNS.

.topic 0x00010030
Поле ввода ограничения кэш DNS.

.topic 0x00010033
Удаляет из кэша выделенную запись DNS.

.topic 0x00010024
Включает блокировку неверных DNS-запросов.

.topic 0x00010034
Отображает визуальное оповещение в случае блокированного DNS-запроса.

.topic 0x204
Список серверов, для которых кэширование не осуществляется.

.topic 0x00010032
Очищает базу данных кэша DNS.

.topic 0x201
Добавляет указанный адрес в список исключений.

.topic 0x0001002b
Нажмите для просмотра базы данных кэша DNS.

.topic 0x0001002d
Нажмите для редактирования списка исключений.

.topic 0x202
Удаляет выделенный сервер из списка исключений.

.topic 0x205
Укажите адрес сервера, который Вы хотите исключить из кэширования.

.topic 0x203
Нажмите для редактирования адреса сервера.

.topic 0x00010025
Позволяет блокировать DNS-запросы с именами доменов четвертого уровня для предотвращения возможной утечки личных данных.

.//============== eo dns ==============

.//============== file_int ==============
.topic 0x00010053
Событие отвечает всем критериям.

.topic 0x0001005e
Событие отвечает одному критерию.

.IDD_FILE_TYPE (2) ********************************************************************************

.topic 0x00010058
Поля ввода описания (расширения) нового типа файлов.

.topic 0x00010059
Поля ввода для нового типа файлов.

.IDD_PAGE_EMAILGUARD (6) **************************************************************************

.topic 0x00010057
Возврат списка файлов и действий в состояние, принятое разработчиками по умолчанию.

.topic 0x0001005a
Список возможных действий для данного типа файлов. Флажок означает выполнение операции.

.topic 0x0001005b
Описание действия для выполнения.

.topic 0x0001005c
Список типов файлов.

.topic 0x0001005d
Добавляет созданное Вами правило с учетом типов файлов.

.topic 0x0001005f
Удаляет выделенный тип файлов из списка.

.//============== eo file_int ==============

.//============== prot_int ==============
.topic 0x00010156
Устанавливает уровень тревоги – максимальный, обычный, минимальный.

.topic 0x0001015a
Флажок включает блокировку IP-адреса взломщика на определенный период, если обнаружено сканирование.

.topic 0x0001015b
Флажок включает блокировку порта, если обнаружена DoS-атака.

.topic 0x0001015c
Флажок включает блокировку подсети взломщика.

.topic 0x00010162
Поле ввода времени блокировки IP-адреса взломщика.

.topic 0x00010172
Флажок включает визуальное оповещение об обнаруженных атаках.

.topic 0x00010163
Число подозрительных пакетов, необходимых для обнаружения атаки.

.topic 0x00010166
Нажмите для редактирования списка доверенных узлов.

.topic 0x00010168
Нажмите для редактирования списка уязвимых портов. Этим портам будет уделено особое внимание.

.topic 0x00010159
Список атак, которые предотвращает Outpost Firewall.

.topic 0x0001016b
Нажмите для добавления порта в список.

.topic 0x0001016d
Укажите десятичное число, определяющее степень важности порта.

.topic 0x00010161
Нажмите для редактирования списка обнаруживаемых атак.

.topic 0x00010171
Нажмите для удаления порта их списка.

.topic 0x0001016c
Укажите протокол.

.topic 0x0001015e
Нажмите для сброса настроек к значениям по умолчанию.

.topic 0x0001016f
Параметры, определяющие как Outpost Firewall обнаруживает атаки.

.topic 0x00010167
Нажмите для редактирования списка доверенных портов.

.topic 0x00010165
Число подозрительных пакетов, необходимых для обнаружения атаки.

.topic 0x00010174
Выберите для отображения визуальных оповещений при обнаружении атаки.

.topic 0x00010155
Нажмите для добавления порта в список.

.topic 0x00010173
Выберите для проигрывания звуковых оповещений при обнаружении атаки.

.topic 0x00010164
Число подозрительных пакетов, необходимых для обнаружения атаки.

.topic 0x00010170
Список уязвимых портов.

.topic 0x0001016a
Введите любую информацию, которая указывает почему данный порт является уязвимым или доверенным.

.topic 0x0001016e
Нажмите, чтобы указать дополнительные настройки обнаружения атак. Эти настройки будут применены ко всем типам атак в списке.

.topic 0x00010157
Нажмите, чтобы сбросить настройки уровней тревоги к значениям по умолчанию.

.topic 0x00010158
Выберите для предотвращения сканирования сети.

.topic 0x0001015d
Позволяет блокировать незапрошенные ARP-ответы.

.topic 0x0001015f
Выберите для блокировки попыток смены MAC-адреса шлюза.

.topic 0x00010160
Выберите для блокировки ложных сообщений о том, что ваш IP-адрес уже используется другой системой.

.topic 0x00010169
Выберите для предотвращения подмены IP-адресов.

.//============== eo prot_int ==============

.//============== web_int ==============
.topic 0x000101ad
Всегда разрешать содержимое данного типа.

.topic 0x000101ae
Однократно разрешить содержимое данного типа.

.topic 0x000101af
Всегда блокировать содержимое данного типа.

.topic 0x000101b0
Однократно блокировать содержимое данного типа.

.topic 0x000101b1
Запомнить текущие настройки и применить их в следующий раз при запросе содержимого данного типа.

.topic 0x000101b2
Добавляет каждый впервые посещенный сайт в список исключений, что дает возможность указывать настройки фильтрации интерактивного содержимого для сайтов индивидуально.

.topic 0x000101b3
Список исключений для узлов.

.topic 0x000101b4
Добавляет узел в список исключений.

.topic 0x000101b5
Нажмите для редактирования индивидуальных настроек фильтрации интерактивного содержимого для узлов.

.topic 0x000101b6
Нажмите для нахождения в списке узла с указанным именем.

.topic 0x000101b7
Нажмите для изменения индивидуальных настроек фильтрации интерактивного содержимого для узлов.

.topic 0x000101b8
Нажмите для удаления выбранного узла из списка.

.topic 0x000101b9
Введите имя искомого узла.

.topic 0x000101ba
Нажмите для добавления нового узла в список исключений.

.topic 0x000101bb
Список интерактивных элементов и настройки их фильтрации.

.topic 0x000101bc
Нажмите для сброса настроек фильтрации интерактивного содержимого для узлов к значениям по умолчанию.

.topic 0x301
Выберите для применения глобальной настройки для элементов данного типа.

.topic 0x302
Выберите, если Вы хотите разрешить элементы данного типа на web-страницах.

.topic 0x303
Выберите, если Вы хотите, чтобы Outpost каждый раз запрашивал разрешение элементов данного типа на web-страницах.

.topic 0x304
Выберите, если Вы хотите запретить элементы данного типа на web-страницах.

.topic 0x305
Выберите, если Вы хотите отображать только первый кадр анимированных GIF изображений.
.//============== eo web_int ==============

.//============== sp_ui ==============
.topic 0x00010175
Добавляет указанный сервер в список.

.topic	0x00010176
Щелкните для добавления новых личных данных для защиты.

.topic	0x00010177
Позволяет указать настройки оповещений об обнаружении spyware.

.//.topic	HIDC_ALWAYS_DO

.topic 0x00010179
Позволяет выбрать файл для проигрывания.

.topic	0x0001017a
Укажите категорию, к которой принадлежит данная строка символов.

.topic	0x0001017b
Щелкните для выбора всех объектов списка.

.//.topic	HIDC_CHECK_ENABLE_REALTIME
.//.topic	HIDC_CHECK_RUN_SCAN

.topic	0x0001017e
Выберите для проверки cookies.

.topic	0x0001017f
Выберите для отображения файлов в дереве.

.topic	0x00010180
Выберите для проверки объектов файловой системы.

.topic	0x00010181
Выберите для проверки запущенных в памяти процессов.

.topic	0x00010182
Выберите для проверки реестра.

.topic	0x00010183
Выберите для проверки параметров автозапуска.

.topic	0x00010184
Щелкните, чтобы удалить обнаруженный объект из вашей системы.

.topic	0x00010185
Список выбранных на данный момент папок.

.topic	0x00010186
Укажите комментарий для описания этих данных.

.topic	0x00010187
Отображает файловую систему в виде дерева папок.

.topic	0x00010188
Укажите адрес сервера для добавления в список доверенных.

.//.topic	HIDC_EDIT_TRUSTED_HOSTS

.topic	0x0001018a
Укажите имя wav-файла для проигрывания.

.topic	0x0001018b
Выберите, если вы хотите защитить указанные личные данные от утечки с вашего компьютера.

.topic	0x0001018c
Выберите, если вы хотите быть постоянно защищены от spyware.

.topic	0x0001018d
Выберите, если вы хотите, чтобы обнаруженные объекты были помещены в карантин перед удалением вместо того, чтобы полностью удалять их из системы.

.topic	0x0001018e
Если выбран этот параметр, Outpost Firewall Pro будет спрашивать вас о дальнейших действиях каждый раз при обнаружении spyware-объекта.

.topic	0x0001018f
Если выбран этот параметр, обнаруженные объекты будут автоматически удаляться.

.topic	0x00010190
Щелкните, чтобы свернуть мастер и продолжить сканирование в фоновом режиме.

.topic	0x00010191
Щелкните для добавления обнаруженного объекта в список исключений.

.topic	0x00010192
Список объектов, которые не рассматриваются Outpost Firewall Pro как spyware и игнорируются во время проверки системы.

.topic	0x00010193
Щелкните для просмотра и редактирования списка исключений.

.topic	0x00010194
Удаляет выбранный объект из списка.

.//.topic	HIDC_IGNORE_SELECTED

.topic	0x00010196
Список доверенных серверов.

.topic	0x00010197
Список уязвимых системных объектов, на которые Outpost Firewall Pro обращает особое внимание.

.topic	0x00010198
Выберите, если хотите получать звуковой сигнал при обнаружении и удалении spyware-объекта.

.topic	0x00010199
Список данных для защиты.

.topic	0x0001019a
Показывает текущее состояние проверки системы.

.topic	0x0001019b
Выберите, если вы хотите проверить конкретные местоположения файловой системы.

.topic	0x0001019c
Если выбран этот параметр, только уязвимые системные папки будут проверены.

.topic	0x0001019d
Если выбран этот параметр, будут проверены все локальные жесткие диски компьютера.

.topic	0x0000801B
Щелкните, чтобы обновить дерево файловой системы.

.topic	0x0001019f
Удаляет выбранный сервер из списка доверенных.

.topic	0x000101a0
Удаляет выбранную строку из списка.

.topic	0x000101a1
Если выбран этот параметр, указанные строки символов будут заменены символами "*" во всех исходящих пакетах, в которых они обнаружены.

.topic	0x000101a2
Отображает краткую статистику проверки системы.

.topic	0x000101a3
Выберите, если хотите указать объекты для проверки вручную.

.topic	0x000101a4
Если выбран этот параметр, будет произведен подробный анализ системы.

.topic	0x000101a5
Если выбран этот параметр, будут проверены только слабые места системы, такие как реестр и уязвимые системные папки.

.topic	0x000101a6
Введите данные, которые вы хотите защитить от несанкционированной утечки с вашего компьютера.

.topic	0x000101a7
Если выбран этот параметр, каждый раз при обнаружении одной из указанный строк в исходящем трафике будет отображаться визуальное оповещение.

.topic	0x000101a8
Выберите, если хотите получать визуальное оповещение каждый раз при обнаружении и удалении spyware-объекта.

.topic	0x000101a9
Список объектов, обнаруженных во время проверки системы.

.topic	0x000101aa
Щелкните для очистки всех объектов списка.

.topic 0
Выберите для включения проактивной проверки процессов при запросе доступа в сеть.

.//.topic	HID_CONTINUE_BKGND
.//.topic	HID_STOP

.//============== eo sp_ui ==============